Bug 701648 - firstboot-text.service doesn't honor "console=ttyS0" and instead displays on tty0, preventing serial login
Summary: firstboot-text.service doesn't honor "console=ttyS0" and instead displays on ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Gracik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F15Blocker, F15FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2011-05-03 13:20 UTC by James Laska
Modified: 2013-09-02 06:56 UTC (History)
6 users (show)

Fixed In Version: firstboot-1.119-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-10 03:25:35 UTC
Type: ---


Attachments (Terms of Use)

Description James Laska 2011-05-03 13:20:03 UTC
Description of problem:

After performing a serial console install, firstboot-text.service doesn't honor "console=ttyS0" and instead displays on tty0.

Version-Release number of selected component (if applicable):
 * firstboot-1.118-1.fc15.x86_64
 * systemd-25-1.fc15.x86_64

How reproducible:


Steps to Reproduce:
1. Follow steps at https://fedoraproject.org/wiki/QA:Testcase_Anaconda_User_Interface_serial_console
2. Make sure to perform a @default package installation (using VNC may be required to select more packages)
3. Complete install, and boot system (ensuring that console=ttyS0 is a boot arg)
  
Actual results:

firstboot-text starts on tty0, and ttyS0 (serial console) hangs waiting for firstboot to complete.

Expected results:

firstboot-text should honor the console= kernel argument, and display over the serial console when booting with "console=ttyS0"

Additional info:
 # I believe this is related to the fix for bug#696320
 # cat /proc/cmdline
ro root=/dev/mapper/vg_test1247-lv_root netroot=iscsi:@10.10.9.219::3260::iqn.1986-03.com.ibm.25166155.20070201123353.qe-rtt-i386-disk1 iscsi_initiator=iqn.rhel5.i386 ip=eth0:dhcp ifname=eth0:52:54:00:f0:b9:a2 rd_LVM_LV=vg_test1247/lv_root rd_LVM_LV=vg_test1247/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us console=ttyS0

 # Impacts the following Fedora 15 beta release criteria (https://fedoraproject.org/wiki/Fedora_15_Beta_Release_Criteria)

   "When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should provide a working login prompt without any unintended user intervention when boot is complete, and all virtual consoles intended to provide a working login prompt should do so "

Comment 1 James Laska 2011-05-03 13:42:02 UTC
Actually, this impacts the Alpha release criteria [1]

    "When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should boot to a state where it is possible to log in through at least one of the default virtual consoles"

[1] https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria

Comment 2 James Laska 2011-05-05 11:35:52 UTC
mgracik: I see this fix in firstboot upstream git [1], but I'm not sure if this is also fixed in firstboot-1.118-1.fc15 [2]?  If so, can you modify the proposed update to include this bug#?

[1] http://git.fedorahosted.org/git/?p=firstboot.git;a=shortlog;h=refs/heads/f15-branch
[2] https://admin.fedoraproject.org/updates/firstboot-1.118-1.fc15

Comment 3 Martin Gracik 2011-05-05 12:50:57 UTC
Fixed in firstboot-1.119-1

Comment 4 Fedora Update System 2011-05-05 13:03:38 UTC
firstboot-1.119-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/firstboot-1.119-1.fc15

Comment 5 Fedora Update System 2011-05-05 21:51:49 UTC
Package firstboot-1.119-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firstboot-1.119-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/firstboot-1.119-1.fc15
then log in and leave karma (feedback).

Comment 6 Tim Flink 2011-05-06 17:48:21 UTC
Discussed in the 2011-05-06 blocker review meeting. Accepted as F15 final blocker under the following alpha release criteria [1]:

"When booting a system installed without a graphical environment, or when
using a correct configuration setting to cause an installed system to boot in
non-graphical mode, the system should boot to a state where it is possible to
log in through at least one of the default virtual consoles"

[1] https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria

Comment 7 Fedora Update System 2011-05-10 03:25:25 UTC
firstboot-1.119-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.