Bug 7017 - key-repeat on/off broken for individual keys
key-repeat on/off broken for individual keys
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-15 11:10 EST by mordibity
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-18 11:12:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mordibity 1999-11-15 11:10:39 EST
[I've asked this question on linux.com, and posted it to
comp.os.linux.x,comp.os.linux.hardware,comp.os.linux.x,
and redhat.x.general.  I've run out of options other than to
submit this bug report.]

I'm running a stock RedHat 6.0/x86 with Enlightenment .15.5.
Try as I might, I cannot get "xset -r <keycode>" to work. I can
globally enable/disable key-repeat using "xset r on" and "xset r
off", but setting individual keycodes (obtained from "xmodmap -pke")
has no effect.

Actually, I can tell that *something* is happening, by
examining the results of "xset -q" before and after:

$ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
auto repeat delay:  500    repeat rate:  5
  auto repeating keys:  00ffffffdffffbbf
                        fa9fffffffdffdff
                        7f00000000000000
                        0000000000000000

$ xmodmap -pke | while read foo key foo ; do xset -r $key ; done
$ xset -q
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
auto repeat delay:  500    repeat rate:  5
  auto repeating keys:  0000000000000000
                        0000000000000000
                        0000000000000000
                        0000000000000000


All this, and the X-server seems to be completely ignoring
the auto_repeats key mask.  I've checked my BIOS; no luck.
I've even tried switching my keyboard (M$Natural) for a stock
Dell QuietKey; no luck.

Any ideas?  Is this an XFree86 problem?  A RedHat problem?
A Linux problem?  A hardware problem?  If anyone can shed
some light, I'd greatly appreciate it.

Thanks,
Rand.
Comment 1 Preston Brown 2000-01-18 11:12:59 EST
xset -r was not implemented in XFree86 until 3.3.6, which is available now in
our rawhide tree, or sometime in the future as an errata for RHL 6.x.
Comment 2 Need Real Name 2000-12-06 03:35:37 EST
I checked it on both XFree86 3.3.6-20j1 of RH6.2J (Japanese version) and XFree86
4.0.1-1 of RH7J, but this problem still exists.

Note You need to log in before you can comment on or make changes to this bug.