Bug 701767 - Suborg allocated only flex entitlements cannot access software channels
Suborg allocated only flex entitlements cannot access software channels
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
540
All Linux
high Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Dimitar Yordanov
:
Depends On:
Blocks: sat541-triage
  Show dependency treegraph
 
Reported: 2011-05-03 15:32 EDT by Alex Dellapenta
Modified: 2012-03-08 04:06 EST (History)
8 users (show)

See Also:
Fixed In Version: spacewalk-schema-1.2.21-16 satellite-schema-5.4.0.19-1
Doc Type: Bug Fix
Doc Text:
Consequence: When only flex entitlements (and no regular) were assigned to an organization, the organization rights were not properly recognized. Result: If an organization has only flex entitlements assigned, access channels rights are properly recognized.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-06 03:23:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Dellapenta 2011-05-03 15:32:00 EDT
Description of problem:

On a 5.4 satellite, if you create a suborganization and only give it flex entitlements, satellite users (even org admins) cannot:

- access the channels overview in the webUI

Channels tab shows "No channels found."

- create Activation Keys that specifies a base channel 

webUI shows "We're sorry, but the channel could not be found." and tomcat logs shows:

2011-04-28 09:29:05,936 [TP-Processor3] WARN  com.redhat.rhn.common.errors.LookupExceptionHandler - User 125 does not have access to channel 121 or the channel does not exist
Apr 28, 2011 5:30:07 PM org.apache.coyote.http11.Http11BaseProtocol pause

- register clients 

fails with Error Class Code: 71

Version-Release number of selected component (if applicable):
RHNS 5.4

How reproducible:
Always

Steps to Reproduce:
1. As sat admin, create suborg in 5.4 webUI
2. Allocate base entitlements and only flex software channel entitlements
3. As new suborg's admin, try to access any channel from the Channel tab, create an Activation Key, or register a client
  
Actual results:

Failure; acts like the user does not have permissions to access the channel.

Expected results:

Success!
Comment 20 Tomas Lestach 2012-01-13 06:06:55 EST
fixed in upstream ... in spacewalk-schema package ...

spacewalk.git: 302ee4c2bc237c6fabf5c411cd2dd8c3e3afad48

for QA: please, try to test several actions, not just those three listed in the #Description
Comment 21 Tomas Lestach 2012-01-13 07:16:25 EST
fixing sha1 of PG upgrade file ...

spacewalk.git: 3f3adfeaef07e76b385456dae74c0f1a1d2ea83a
Comment 24 Tomas Lestach 2012-01-31 08:28:26 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Consequence:
When only flex entitlements (and no regular) were assigned to an organization, the organization rights were not properly recognized.
Result:
If an organization has only flex entitlements assigned, access channels rights are properly recognized.
Comment 30 errata-xmlrpc 2012-02-06 03:23:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0097.html

Note You need to log in before you can comment on or make changes to this bug.