Bug 7018 - system-level daemons should have TFM
system-level daemons should have TFM
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-15 11:38 EST by Ole Craig
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-01 14:37:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ole Craig 1999-11-15 11:38:21 EST
I've noticed that many of the system-level building blocks that RedHat
uses are starting to ship without manpages. Ok, I can see gnomehelp or info
pages for userland programs and GUI-related things, but IMnsHO there's no
excuse for shipping system binaries without manpages. While I've seen this
occur with other programs, my beef today is particularly with "ppp-watch"
which seems to be new to rh6.1 -- would it be too difficult to explain
*somewhere* what this program does, what arguments can be passed to it,
what its exit values are, etc? While I *can* go find the source and figure
it out for myself, that's a little difficult when I'm trying to figure out
where the interface configuration is bombing...

	IOW, I'd be happy to RTFM if there *was* a FM. If indeed there is
one, I will happily apologize, swallow my irritation, and publicly flog
myself in return for a pointer to it.
Comment 1 Michael K. Johnson 1999-11-17 10:41:59 EST
It is not documented because it is not intended to be called
directly.  Perhaps it should be in /lib/initscripts/ or something
like that...  It is intended to be called ONLY via ifup-ppp and
not other use is encouraged.
Comment 2 Ole Craig 1999-11-17 12:25:59 EST
The fact that RedHat doesn't intend for ppp-watch to be called directly doesn't
mean that end-users won't need information on it in order to debug problems in
the field. Hell, getty is supposed to be invoked only by init, and there's three
different getty-related manpages...

Let me highlight my underlying complaint here: system binaries should be
documented. In particular, system binaries without which critical functionality
(such as remote or network connectivity) is lost *must* be documented in order
for the open-source development model to remain viable. (How can I tell whether
it's a bug if I don't have information on what the program should be doing? How
can I tell which part of the connection process is failing if I don't know what
parts are doing what?)

	So yes, I think that at a minimum there should be information left in
/usr/doc/initscripts-%{version}, if not a complete manpage. Two lines in the rpm
changelog doesn't cut it.
Comment 3 Michael K. Johnson 1999-11-19 16:53:59 EST
You are right.  I have added ppp-watch.8 for the next release of initscripts.

Note You need to log in before you can comment on or make changes to this bug.