Bug 701878 - Allow to auto-select locale for coregui
Allow to auto-select locale for coregui
Status: CLOSED DUPLICATE of bug 752215
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0
Unspecified Unspecified
medium Severity unspecified (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-04 03:15 EDT by Heiko W. Rupp
Modified: 2012-02-13 14:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-13 14:03:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko W. Rupp 2011-05-04 03:15:07 EDT
Currently the user when he wants German messages, has to add ?locale=de at the end of the url as in
http://localhost:7080/coregui?locale=de

There should be an automatic way to select the locale, as the browser is already sending the preferred locales.

See e.g. http://google-web-toolkit.googlecode.com/svn/javadoc/1.6/com/google/gwt/i18n/client/LocaleInfo.html#getCurrentLocale()- this seems to allow to get the wanted locale from the browser
Comment 1 John Mazzitelli 2012-02-13 14:03:43 EST

*** This bug has been marked as a duplicate of bug 752215 ***

Note You need to log in before you can comment on or make changes to this bug.