Bug 70189 - language support: to few options?
language support: to few options?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-config-kickstart (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-30 19:18 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-06 16:55:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-07-30 19:18:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
It's not clear whether the Languages selected there are the languages to be used
during the installation process or in the installed localization packages.  I
believe it's the latter, but a lot of options are missing (Brazilian Portuguese,
for one), and there's no way to indicate what the default language should be. 
In fact, the list of languages seems to match that presented in the beginning of
an interactive install, to choose the list of languages to be used during the
installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start redhat-config-kickstart
2.Scratch head trying to figure out how to choose the default language
3.Scratch it more trying to guess whether choosing Portuguese will get you pt_BR too
	

Actual Results:  Confusion :-)

Expected Results:  Some way to choose the default language, and as many language
options as there are in the installer.

Additional info:
Comment 1 Tammy Fox 2002-08-02 16:29:53 EDT
You can only select one language in the Language pulldown menu. This is
the one used during installation. In the Language Support list, you can
select multiple languages to be installed for use post-install. I just
updated the language list with the same list used in anaconda.

You can select the same languages in redhat-config-kickstart as you
can in the installer. I don't think this is a bug. Please reopen
if I am misunderstanding your report.
Comment 2 Alexandre Oliva 2002-08-02 16:35:39 EDT
Eek.  I had completely missed the Language pull-down menu, which has probably
made my report sound much more confusing.  Sorry about that.  Indeed, all I
wanted was to have the same options in `Language Support' as in anaconda. 
However, I don't see how to select the default language to be used post install.
 Isn't such an option missing?
Comment 3 Brent Fox 2002-08-05 10:33:11 EDT
No.  The language that you select in the top language combo box will be the
default language both during installation and after.  The language support list
controls which languages get installed on the system, but not the default.  Does
this answer your question?
Comment 4 Alexandre Oliva 2002-08-05 14:11:25 EDT
Yes, it does.  I'm afraid it's not clear from the screen, though.  Perhaps the
language choice should be moved below, next to language support, and rephrased
to `Default language (install and run-time)'.
Comment 5 Brent Fox 2002-08-11 09:19:21 EDT
Hmmm, you have a point, but it's getting pretty late to be switching widgets
around.  I think tfox is planning on taking the screenshots in the next day or
so.  I will defer this for now but will revisit this for the next release.
Comment 6 Jay Turner 2002-08-13 12:33:22 EDT
Deferring.
Comment 7 Brent Fox 2002-12-13 10:37:05 EST
I've done some more thinking about this one.  I've changed the string from
"Language" to "Default Language".  I considered changing the GUI around and
played with it in Glade for a while, but I've decided to leave it the way it is.  

It's not perfect, but each widget on the screen is adequately described in the
Help documentation.  Closing as 'rawhide' since I did make that string change. 
redhat-config-kickstart-2.3.5-4 should contain the new string.  QA, please verify.
Comment 8 Brent Fox 2003-05-25 10:30:01 EDT
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.
Comment 9 Alexandre Oliva 2003-10-18 14:00:03 EDT
Wording it as `Default Language' makes it much clearer, but Fedora Core test3 is
still missing `Brazilian Portuguese' as a Language Support choice.  I'm pretty
sure the list redhat-config-kickstart displays is far shorter than the one
displayed by the installer.  Is this on purpose?  Couldn't we have a single list
used by both?
Comment 10 Brent Fox 2004-01-06 16:55:51 EST
I've added code so that system-config-kickstart now pulls the language
list from system-config-languages.  Should be fixed in
system-config-kickstart-2.5.3-1.  Thanks for your report.
Comment 11 Alexandre Oliva 2004-02-24 14:17:04 EST
Confirmed fixed in current FC development tree (2.5.4-1.1).  Sorry
that it took so long.

Note You need to log in before you can comment on or make changes to this bug.