Bug 70193 - Raid Members choices are broken
Summary: Raid Members choices are broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-kickstart (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-30 23:30 UTC by Alexandre Oliva
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 21:38:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2002-07-30 23:30:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
The list of options displayed for `Raid Members' is confusing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create 2 RAID partitions of the same size (500), onpart /dev/hda1 and /dev/hda2
2.Choose `Make RAID Device' -> Create a RAID device (/dev/md0)

	

Actual Results:  The list of options looks like:
< > raid 01 < > raid 01 < > raid 01
< > raid 02 < > raid 02 < > raid 02

i.e., each RAID device appears 3 times.
Clicking on the check boxes on the left, I get a traceback:
Traceback (most recent call last):
  File "/usr/share/redhat-config-kickstart/raidWindow.py", line 92, in
partitionToggled
    iter = self.raid_partition_store.get_iter((int(row),))
ValueError: invalid tree path

Clicking on the check boxes in the middle column does nothing.

Clicking on the check boxes in the right column selects all 3 items of that line.

This looks very odd.

Expected Results:  I suppose there should be only one check box per RAID partition.

Additional info:

Comment 1 Brent Fox 2002-08-21 21:38:48 UTC
Should be fixed in 2.3.2-16. 

QA, please verify.

Comment 2 Jay Turner 2002-08-29 12:31:44 UTC
Fix confirmed with redhat-config-kickstart-2.3.3-1.


Note You need to log in before you can comment on or make changes to this bug.