Bug 701931 - Guest cannot reboot after doing kdump
Guest cannot reboot after doing kdump
Status: CLOSED DUPLICATE of bug 611407
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Gleb Natapov
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-05-04 06:46 EDT by dengmin
Modified: 2013-12-08 19:54 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-18 08:28:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dengmin 2011-05-04 06:46:59 EDT
Description of problem:
Guest should reboot after doing kdump

Version-Release number of selected component (if applicable):
KVM Version is kvm-83-232.el5

How reproducible:
The issue can be always reproduced 

Steps to Reproduce:
---------------------------------cmdline----------------------------------------
 /usr/libexec/qemu-kvm -rtc-td-hack -usbdevice tablet -no-hpet -drive file=/hom/5u7.raw,if=virtio,boot=on,werror=stop,cache=none,format=raw,media=disk -smp 2 -m 4G -net nic,macaddr=00:12:24:57:a8:2e,model=virtio,vlan=0 -net tap,script=/etc/qemu-ifup,vlan=0 -uuid `uuidgen` -boot c -balloon none -notify all -spice port=8001,disable-ticketing -monitor stdio -qxl 1
-------------------------------------------------------------------------------
1.install guest RHEL5.7 and enable kdump during installation process
2.boot up guest and check grub.conf (please refer to additional info)
3.chkconfig kdump on
4.service kdump start
5.test kdump: 
# echo c > /proc/sysrq-trigger
  
Actual results:
The guest became non operational but its status was 'running' in monitor

Expected results:
The guest reboot successfully

Additional info:
grub.conf 
-------------------------------------------------------------------------------
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux Server (2.6.18-259.el5)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-259.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet crashkernel=128M@16M
        initrd /initrd-2.6.18-259.el5.img
Comment 1 dengmin 2011-05-04 06:47:35 EDT
kernel version 
2.6.18-259.el5
Comment 2 dengmin 2011-05-04 06:49:05 EDT
Try the similar steps on host but tester don't reproduce the issue.
Comment 3 Mike Cao 2011-05-04 07:29:33 EDT
hit the same issue on RHEL6.1 host& RHEL5.7 guest

host info:
# uname -r
2.6.32-131.0.10.el6.x86_64
[root@localhost ~]# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.160.el6.x86_64

Guest info:
2.6.18-259.el5
Comment 4 Mike Cao 2011-05-04 22:11:52 EDT
(In reply to comment #3)
> hit the same issue on RHEL6.1 host& RHEL5.7 guest
> 
> host info:
> # uname -r
> 2.6.32-131.0.10.el6.x86_64
> [root@localhost ~]# rpm -q qemu-kvm
> qemu-kvm-0.12.1.2-2.160.el6.x86_64
> 
> Guest info:
> 2.6.18-259.el5

Can not reproduce 100 % times ,I trigger this issue 2/10 times .
Comment 5 Gleb Natapov 2011-05-18 08:28:27 EDT

*** This bug has been marked as a duplicate of bug 611407 ***

Note You need to log in before you can comment on or make changes to this bug.