Bug 701973 - Duplicate posts navigating top-level menus
Duplicate posts navigating top-level menus
Status: CLOSED WORKSFORME
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.Beta2
All All
urgent Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks: jon30-bugs rhq41 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-05-04 08:53 EDT by Mike Foley
Modified: 2013-08-05 20:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-16 13:56:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Firebug display showing duplicate posts (25.26 KB, image/png)
2011-05-04 08:53 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2011-05-04 08:53:07 EDT
Created attachment 496782 [details]
Firebug display showing duplicate posts

Description of problem:

Duplicate posts navigating top-level menus.  possible performance impact doing double the work unneccessarily.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  FF, with Firebug plugin
2.  Navigate top-level menus
3.  Observe posts
  
Actual results:

see attached screenshot.  duplicate posts.  the contents of the http posts are identical.  

5|0|25|http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/|9B84EF9F58D797B7E2F3899A5AA5B0C6|org.rhq.enterprise.gui.coregui.client.gwt.BundleGWTService|findBundlesByCriteria|org.rhq.core.domain.criteria.BundleCriteria/7774234|java.util.HashMap/962170901|java.lang.String/2004016611|tag|id IN ( SELECT taggedEntity.id FROM Bundle taggedEntity JOIN taggedEntity.tags tag WHERE (tag.namespace LIKE :tagNamespace OR :tagNamespace IS NULL ) AND (tag.semantic LIKE :tagSemantic OR :tagSemantic IS NULL ) AND (tag.name LIKE :tagName OR :tagName IS NULL ) )|bundleVersionIds|id IN ( SELECT bv.bundle.id FROM BundleVersion bv WHERE bv.id IN ( ? ) )|bundleTypeId|bundleType.id = ?|bundleTypeName|bundleType.name like ?|destinationIds|id IN ( SELECT bd.bundle.id FROM BundleDestination bd WHERE bd.id IN ( ? ) )|packageTypeId|packageType.id = ?|packageTypeName|packageType.name like ?|java.util.ArrayList/3821976829|org.rhq.core.domain.util.PageControl/1930924326|java.util.LinkedList/1060625595|java.lang.Integer/3438268394|1|2|3|4|1|5|5|0|1|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|6|7|7|8|7|9|7|10|7|11|7|12|7|13|7|14|7|15|7|16|7|17|7|18|7|19|7|20|7|21|0|22|0|23|0|24|0|0|100|25|0|25|200|0|0|0|6|0|0|



5|0|25|http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/|9B84EF9F58D797B7E2F3899A5AA5B0C6|org.rhq.enterprise.gui.coregui.client.gwt.BundleGWTService|findBundlesByCriteria|org.rhq.core.domain.criteria.BundleCriteria/7774234|java.util.HashMap/962170901|java.lang.String/2004016611|tag|id IN ( SELECT taggedEntity.id FROM Bundle taggedEntity JOIN taggedEntity.tags tag WHERE (tag.namespace LIKE :tagNamespace OR :tagNamespace IS NULL ) AND (tag.semantic LIKE :tagSemantic OR :tagSemantic IS NULL ) AND (tag.name LIKE :tagName OR :tagName IS NULL ) )|bundleVersionIds|id IN ( SELECT bv.bundle.id FROM BundleVersion bv WHERE bv.id IN ( ? ) )|bundleTypeId|bundleType.id = ?|bundleTypeName|bundleType.name like ?|destinationIds|id IN ( SELECT bd.bundle.id FROM BundleDestination bd WHERE bd.id IN ( ? ) )|packageTypeId|packageType.id = ?|packageTypeName|packageType.name like ?|java.util.ArrayList/3821976829|org.rhq.core.domain.util.PageControl/1930924326|java.util.LinkedList/1060625595|java.lang.Integer/3438268394|1|2|3|4|1|5|5|0|1|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|6|7|7|8|7|9|7|10|7|11|7|12|7|13|7|14|7|15|7|16|7|17|7|18|7|19|7|20|7|21|0|22|0|23|0|24|0|0|100|25|0|25|200|0|0|0|6|0|0|

Expected results:
no unneccessary duplicate posts

Additional info:
Comment 1 Charles Crouch 2011-08-11 22:52:15 EDT
setting this to urgent, to see if addressing it will improve overall UI 
stability any. Its not on its own a serious issue, so priority can be dropped 
if fixing doesn't help the effort.
Comment 2 Ian Springer 2011-08-16 13:56:49 EDT
I'm unable to reproduce this. When I click on the Bundles top menu link, I see two POSTs in Firebug, but they are not identical - one is a call to findBundlesWithLatestVersionCompositesByCriteria:

5|0|25|http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/|F03AEAEAD2B3C2FD0424523CC46F9014|org.rhq.enterprise.gui.coregui.client.gwt.BundleGWTService|findBundlesWithLatestVersionCompositesByCriteria|org.rhq.core.domain.criteria.BundleCriteria/7774234|java.util.HashMap/962170901|java.lang.String/2004016611|bundleTypeId|bundleType.id = ?|bundleVersionIds|id IN ( SELECT bv.bundle.id FROM BundleVersion bv WHERE bv.id IN ( ? ) )|destinationIds|id IN ( SELECT bd.bundle.id FROM BundleDestination bd WHERE bd.id IN ( ? ) )|packageTypeName|packageType.name like ?|tag|id IN ( SELECT taggedEntity.id FROM Bundle taggedEntity JOIN taggedEntity.tags tag WHERE (tag.namespace LIKE :tagNamespace OR :tagNamespace IS NULL ) AND (tag.semantic LIKE :tagSemantic OR :tagSemantic IS NULL ) AND (tag.name LIKE :tagName OR :tagName IS NULL ) )|packageTypeId|packageType.id = ?|bundleTypeName|bundleType.name like ?|java.util.ArrayList/3821976829|org.rhq.core.domain.util.PageControl/1930924326|java.lang.Integer/3438268394|java.util.LinkedList/1060625595|1|2|3|4|1|5|5|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|6|7|7|8|7|9|7|10|7|11|7|12|7|13|7|14|7|15|7|16|7|17|7|18|7|19|7|20|7|21|0|22|0|23|24|0|25|0|0|999|-19|24|200|0|0|0|6|0|0|

and the other a call to findBundlesByCriteria:

5|0|25|http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/|F03AEAEAD2B3C2FD0424523CC46F9014|org.rhq.enterprise.gui.coregui.client.gwt.BundleGWTService|findBundlesByCriteria|org.rhq.core.domain.criteria.BundleCriteria/7774234|java.util.HashMap/962170901|java.lang.String/2004016611|bundleTypeId|bundleType.id = ?|bundleVersionIds|id IN ( SELECT bv.bundle.id FROM BundleVersion bv WHERE bv.id IN ( ? ) )|destinationIds|id IN ( SELECT bd.bundle.id FROM BundleDestination bd WHERE bd.id IN ( ? ) )|packageTypeName|packageType.name like ?|tag|id IN ( SELECT taggedEntity.id FROM Bundle taggedEntity JOIN taggedEntity.tags tag WHERE (tag.namespace LIKE :tagNamespace OR :tagNamespace IS NULL ) AND (tag.semantic LIKE :tagSemantic OR :tagSemantic IS NULL ) AND (tag.name LIKE :tagName OR :tagName IS NULL ) )|packageTypeId|packageType.id = ?|bundleTypeName|bundleType.name like ?|java.util.ArrayList/3821976829|org.rhq.core.domain.util.PageControl/1930924326|java.util.LinkedList/1060625595|java.lang.Integer/3438268394|1|2|3|4|1|5|5|0|1|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|6|7|7|8|7|9|7|10|7|11|7|12|7|13|7|14|7|15|7|16|7|17|7|18|7|19|7|20|7|21|0|22|0|23|0|24|0|0|100|25|0|25|200|0|0|0|6|0|0|

Note You need to log in before you can comment on or make changes to this bug.