Bug 701983 - Double posts to getExplicitGlobalPermissions navigating groups in left-nav
Summary: Double posts to getExplicitGlobalPermissions navigating groups in left-nav
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: RHQ Project
Classification: Other
Component: Core Server
Version: 4.0.0.Beta2
Hardware: All
OS: All
urgent
medium vote
Target Milestone: ---
: ---
Assignee: Ian Springer
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: jon30-bugs rhq41 rhq41-ui
TreeView+ depends on / blocked
 
Reported: 2011-05-04 13:20 UTC by Mike Foley
Modified: 2013-08-06 00:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-16 19:47:49 UTC


Attachments (Terms of Use)
2 posts to getexplicitpermissions (46.06 KB, image/png)
2011-05-04 13:20 UTC, Mike Foley
no flags Details

Description Mike Foley 2011-05-04 13:20:32 UTC
Created attachment 496788 [details]
2 posts to getexplicitpermissions

Description of problem:
Double posts to getExplicitGlobalPermissions navigating groups in left-nav.  Possible performance impact with both server and UI doing twice the work unneccessarily.  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  FF, with Firebug plugin
2.  Navigate Groups in left-nav
3.  Observe double posts to getExplicitGlobalPermissions.  Contents of posts requests are identical.
  
Actual results:

Double posts.  Muda.


Expected results:

Single posts.

Additional info:

see attached image.  Also, documenting the contents of the post below:
5|0|4|http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/|F1F6D738F3DE07FD8AF83458D7413F92|org.rhq.enterprise.gui.coregui.client.gwt.AuthorizationGWTService|getExplicitGlobalPermissions|1|2|3|4|0|

Comment 1 Charles Crouch 2011-08-12 02:52:53 UTC
setting this to urgent, to see if addressing it will improve overall UI 
stability any. Its not on its own a serious issue, so priority can be dropped 
if fixing doesn't help the effort.

Comment 2 Ian Springer 2011-08-16 19:47:49 UTC
This is because there are two action buttons on the groups list views which extend AuthorizedTableAction - the Delete button and the New button. Each AuthorizedTableAction will make an RPC call to retrieve the global permissions. We could optimize this so that a single call to load the global perms is made by the Table itself and all AuthorizedTableActions share the results, but since getExplicitGlobalPermissions is a very inexpensive call and there will never be more than a handful of AuthorizedTableActions for a given Table, it's really not worth the effort.


Note You need to log in before you can comment on or make changes to this bug.