Bug 70200 - ifdown-post removes ppp peers' config
ifdown-post removes ppp peers' config
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 78984
  Show dependency treegraph
 
Reported: 2002-07-30 21:12 EDT by Matthew Melvin
Modified: 2014-03-16 22:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 16:10:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
sample /etc/ppp/peers/ppp0 for pptp connection (166 bytes, text/plain)
2002-07-30 21:15 EDT, Matthew Melvin
no flags Details
sample /etc/sysconfig/network-scripts/ifcfg-ppp0 file for pptp (195 bytes, text/plain)
2002-07-30 21:16 EDT, Matthew Melvin
no flags Details

  None (edit)
Description Matthew Melvin 2002-07-30 21:12:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
After a ppp interface is taken down the ifdown-post script unconditionally
removes /etc/ppp/peers/${DEVICE} file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create customer peers config like /etc/ppp/peers/ppp0
2. ifup ppp0
3. ifdown ppp0

Actual Results:  The /etc/ppp/peers/ppp0 config file is gone.

Expected Results:  The /etc/ppp/peers/ppp0 config file should still be there.
ifup-ppp will create a peers config if one doesn't already exist which contains
just the chat command pointing at the chat-${$DEVICE} file.  ifdown-post should
either not delete the config file at all or only delete it if it knows it
created it in the first place.

Additional info:

Having a custom peers config makes it very easy to create a pptp tunnel that can
be manipulated with ifup/ifdown ect just like any other ordinary ppp connection.
 Since getting pptp to work at all requires installing a custom pptp and kernel
package anyway making a small mod to the init scripts is hardly a chore.  Still
it'd be nice it worked as expected.
Comment 1 Matthew Melvin 2002-07-30 21:15:20 EDT
Created attachment 67804 [details]
sample /etc/ppp/peers/ppp0 for pptp connection
Comment 2 Matthew Melvin 2002-07-30 21:16:25 EDT
Created attachment 67805 [details]
sample /etc/sysconfig/network-scripts/ifcfg-ppp0 file for pptp
Comment 3 Bill Nottingham 2002-08-13 21:41:38 EDT
Than, do you recall why we remove the peer config?
Comment 4 Ngo Than 2002-08-14 09:51:15 EDT
if i'm not wrong, it was a problem by changing of nickname.

If the user changes the nickname (not device name), the ppp peers' config still
has the old nickname there. It will fail by next ifup with old argument --chat
NICKNAME.
Comment 5 MIchael Kolmodin 2002-12-04 08:53:06 EST
My workaround has been to use the ifup-pre-local script (a hook in ifup) to 
copy a fresh copy of the configuration to /etc/ppp/peers. Clumsy, bit it works
without patching existing scripts.

Note: removing the file is just plain wrong. The peers file is well documented
in pppd, and removing these files violates whats described there
Comment 6 Bill Nottingham 2005-09-29 16:10:30 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.