Bug 70204 - can't upload hardware profile of Dell Inspiron 8000
can't upload hardware profile of Dell Inspiron 8000
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2002-07-30 21:32 EDT by Alexandre Oliva
Modified: 2015-01-07 18:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-08 17:05:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-07-30 21:32:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
When registering my limbo (7.3.93) install (everything) on my laptop, it bombed
with an exception during the upload of the hardware profile.  To my surprise,
registration had completed, and I could run up2date properly.  But up2date
--hardware fails with the same error.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.run up2date to register the install (it crashes at the end)
2.run up2date to see there are no new packages
2.run up2date --hardware


Actual Results:  Traceback (most recent call last):
  File "/usr/sbin/up2date", line 801, in ?
  File "/usr/sbin/up2date", line 361, in main
  File "/usr/share/rhn/up2date_client/rhnHardware.py", line 23, in updateHardware
  File "/usr/lib/python2.2/xmlrpclib.py", line 821, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.2/site-packages/rhn/rpclib.py", line 122, in _request
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 132, in request
    return self.parse_response(fd)
  File "/usr/lib/python2.2/site-packages/rhn/transports.py", line 152, in
    return u.close()
  File "/usr/lib/python2.2/xmlrpclib.py", line 571, in close
    raise apply(Fault, (), self._stack[0])
xmlrpclib.Fault: <Fault 1: 'While running \'registration.refresh_hw_profile\':
caught\nexceptions.KeyError : ("Don\'t know how to parse key `usbprod\'\'",
{\'desc\': \'"USB UHCI Root Hub"\', \'usbprotocol\': \'0\', \'usbport\': \'0\',
\'usbprod\': \'USB UHCI Root Hub\', \'class\': \'OTHER\', \'deviceId\':
\'0000\', \'usbsubclass\': \'0\', \'usbbus\': \'1\', \'usbclass\': \'9\',
\'driver\': \'unknown\', \'bus\': \'USB\', \'usblevel\': \'0\', \'detached\':
\'0\', \'vendorId\': \'0000\'})\n'>

Expected Results:  erhm.  it should just work?

Additional info:

This is a Dell Inspiron 8000.  lspci -v has the following to say about the USB

00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 02) (prog-if
00 [UHCI])
        Subsystem: Intel Corp.: Unknown device 4541
        Flags: bus master, medium devsel, latency 0, IRQ 10
        I/O ports at bce0 [size=32]

I don't have any USB devices connected to the laptop (that I know :-)
Comment 1 Adrian Likins 2002-08-02 15:07:59 EDT
`usbprod ` is a new field for usb stuff. The server wasnt ready
to accept it, so returned this fault. Should be fixed
in current server code now.
Comment 2 Chris Ricker 2002-08-08 10:00:25 EDT
It's not fixed (or if it is, the fixed code isn't what's running on the server).
 I just got the same error on a system here....
Comment 3 Chris 2002-08-08 17:05:48 EDT
I have the same error on a Dell Latitude C600 laptop.
Comment 4 Chris Ricker 2002-08-24 22:05:03 EDT
This seems fixed now -- I'm able to update hardware w/ beta5

Note You need to log in before you can comment on or make changes to this bug.