Bug 70205 - minimum size of window list sets a maximum size as well
minimum size of window list sets a maximum size as well
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: MoveUpstream
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-07-30 21:49 EDT by John J. Germs
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-12 21:08:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John J. Germs 2002-07-30 21:49:03 EDT
Description of Problem:

Window List (tasklist) will not change size. It remains a fixed size of approx.
1 inch no matter how many tasks there are, resulting in all tasks becoming a
sliver in thickness when numerous tasks are running.


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:
Window List (tasklist) should change in size corresponding to value entered. It
should also have the ability to be dynamic in size depending on number os
current tasks.

Additional Information:


My System Specs:

Athlon XP 1900+
Soyo Dragon Ultra
Leadtek GeForce4 Ti 4600
512 meg ram
Comment 1 Jens Petersen 2002-07-31 05:12:22 EDT
Isn't the problem that the window list is being placed in the wrong place
by default currently (between evolution and mozilla), whereas it should go
in the middle (to the right of the yelp button) where there is plenty of
space?
Comment 2 Havoc Pennington 2002-07-31 09:06:31 EDT
Yes, I don't think there's a window list bug, it's just that you need the window
list placed where there's space.
Comment 3 John J. Germs 2002-07-31 19:49:57 EDT
Boy you guys are quick to close these things... geepers.
I submit it yesterday afternoon then I get back from work today and it's already
closed.

Anyways.

The Window List (tasklist) is never big enough .. really ... To demonstrate all
you have to do is create a sliding panel and create a Window List (tasklist) on
it and see what happens. It is should become dynamic in size like it used to in
earlier versions.

If it matters I'm at 1280x1024 using  X small 24 pixels
Comment 4 Havoc Pennington 2002-07-31 21:23:12 EDT
If you have a dynamic-sized panel you need to set a minimum size on the task
list in the preferences.
Comment 5 Jens Petersen 2002-07-31 22:18:04 EDT
Right, but the default placement needs to be fixed, so that it is in that place.
;-)
Comment 6 Jens Petersen 2002-07-31 22:20:27 EDT
(Should I file a separate bug for that, or is it already fixed?)
Comment 7 Havoc Pennington 2002-07-31 22:31:38 EDT
That bug is already open as #69706 (marked private though because it has some
random internal info in it, so I can't mark this one as a dup)
Comment 8 John J. Germs 2002-07-31 23:06:57 EDT
So .. Yes .. that increased the size of the Window List (tasklist) ... Now I can
read the tasks... 
It sure works different than it used to.. 
Before, every task was a fixed size and the panel would grow until it reached
its maximum then the tasks would start to decrease in size.
But now the minimum size refers to the "tasklist" 
(which doesn't seem to be enough by default the way things are currently
working) and the maximum size relates to each task ??
I guess that means that if you have a sliding panel with a tasklist residing in
it your sliding panel will be dynamic in size plus the length of the fixed
tasklist....?

One thing I still don't understand then is where does the maximum Window List
(tasklist) size come into play?? I still think it is supposed to grow in size
until it reaches the "maximum" ... am I wrong?

Comment 9 Havoc Pennington 2002-07-31 23:10:24 EDT
as far as I know it's very simple; the window list takes exactly the size needed
for the window buttons, until it reaches maximum size that's been set in prefs,
or hits another applet in the way, and then it starts shrinking or grouping buttons.
If there's a minimum size it always takes at least that much size. I'm pretty
sure that's it, not too complicated.

If you set a max size and a min size that are the same, then you should get a
fixed-size applet and a fixed-size sliding panel.
Comment 10 John J. Germs 2002-07-31 23:15:07 EDT
Yes that makes sense, but the maximum does nothing. The Window List (tasklist)
always remains the minimum size and never grows... The first task is the full
minimum size. Once I add another task it stays the minimum size and hlaves the
size of the tasks even though the maximum can be set to double or triple...
Comment 11 Havoc Pennington 2002-07-31 23:17:54 EDT
Ah, got it.
Comment 12 Havoc Pennington 2003-01-12 21:08:58 EST
Moved to http://bugzilla.gnome.org/show_bug.cgi?id=103246

Note You need to log in before you can comment on or make changes to this bug.