Bug 702067 - fedora-icon-theme inherits Mist but does not depend on gnome-themes (where the Mist icon theme lives)
fedora-icon-theme inherits Mist but does not depend on gnome-themes (where th...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-icon-theme (Show other bugs)
15
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
AcceptedNTH
:
: 702070 (view as bug list)
Depends On:
Blocks: F15Blocker-xfce
  Show dependency treegraph
 
Reported: 2011-05-04 12:56 EDT by Andrew McNabb
Modified: 2011-05-18 05:54 EDT (History)
10 users (show)

See Also:
Fixed In Version: fedora-icon-theme-1.0.0-10.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-08 23:55:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot showing missing icons in thunar (34.34 KB, image/png)
2011-05-04 12:56 EDT, Andrew McNabb
no flags Details

  None (edit)
Description Andrew McNabb 2011-05-04 12:56:43 EDT
Created attachment 496853 [details]
screenshot showing missing icons in thunar

In Thunar, none of the folders have any folder icon.  Instead, there is blank space where the icon should be.  I'm attaching a screenshot to make the problem clear.  The package version is Thunar-1.2.1-5.fc15.x86_64.  Please let me know if there is any other information that would be helpful.  Thanks.
Comment 1 Kevin Fenzi 2011-05-04 13:23:55 EDT
What does: 

'rpm -qa | grep icon-theme' output? 

If you do a 'yum groupinstall xfce-desktop' does it install some icon-themes?
Comment 2 Andrew McNabb 2011-05-04 14:41:24 EDT
amcnabb@sage:~ :) rpm -qa | grep icon-theme
gnome-icon-theme-extras-3.0.0-1.fc15.noarch
oxygen-icon-theme-4.6.2-1.fc15.noarch
fedora-icon-theme-1.0.0-9.fc15.noarch
gnome-icon-theme-symbolic-3.0.0-1.fc15.noarch
hicolor-icon-theme-0.12-2.fc15.noarch
gnome-icon-theme-3.0.0-1.fc15.noarch
gnome-icon-theme-legacy-3.0.0-1.fc15.noarch
xfce4-icon-theme-4.4.3-5.fc15.noarch
amcnabb@sage:~ :)

With the yum groupinstall command, it reports: "No packages in any requested group available to install or update".
Comment 3 Christoph Wickert 2011-05-04 17:15:18 EDT
What Icon theme did you select? Please run

$ grep Icon ~/.config/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml 

and post the output here
Comment 4 Andrew McNabb 2011-05-04 17:36:23 EDT
I don't think I ever selected an icon theme, so presumably it's using whatever the default is.

amcnabb@sage:~ :) grep Icon ~/.config/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml
    <property name="IconThemeName" type="empty"/>
    <property name="IconSizes" type="string" value=""/>
    <property name="ToolbarIconSize" type="int" value="3"/>
amcnabb@sage:~ :)
Comment 5 Adam Williamson 2011-05-04 20:22:11 EDT
*** Bug 702070 has been marked as a duplicate of this bug. ***
Comment 6 Adam Williamson 2011-05-04 20:24:36 EDT
As discussed with Kevin in IRC, there are actually all sorts of icon problems
in a current default Xfce desktop - missing and incorrect icons in the panel
and notification area and system menus, all caused by that

    <property name="IconThemeName" type="empty"/>

issue. Marking as Xfce 'blocker' (so NTH as far as the distro is concerned) as
it's an obvious polish issue with the Xfce desktop and breaks the criteria,
most obviously 'All Applications listed in the desktop menus must have icons
which have a consistent appearance and sufficiently high resolution to avoid
appearing blurry'.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Adam Williamson 2011-05-04 20:26:26 EDT
As per Kevin's request - switching to the 'GNOME' setting in Preferences -> Appearance -> Icons 'fixes' the bug, all missing / broken icons are resolved. Switching back to 'Fedora' (the setting that's highlighted by default when you go to that tab), however, does not result in a working 'Fedora' icon set, but goes back to the broken case, many icons missing.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Adam Williamson 2011-05-04 20:28:25 EDT
fedora-icon-theme-1.0.0-9.fc15.noarch is installed.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Adam Williamson 2011-05-04 20:31:15 EDT
Ah - fedora-icon-theme has no icons in it, only a bit of configuration and an 'Inherits=Mist'. The Mist theme is part of gnome-themes, and that's not installed; obviously GNOME 3 doesn't use it. fedora-icon-theme should inherit something else, or depend on gnome-themes. It depends on gnome-icon-theme, so perhaps it should Inherits=gnome (the name of the theme in gnome-icon-theme) instead?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Adam Williamson 2011-05-04 20:31:41 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Christoph Wickert 2011-05-05 04:18:59 EDT
I'm afraid I caused this when I filed bug 682444
Comment 12 Kevin Fenzi 2011-05-05 09:19:44 EDT
Argh. Yeah. ;( 

We need gnome-themes for Mist. ;( 

So, should we ask for reverting 682444? Or should we just add gnome-themes to the Xfce ks and group?
Comment 13 Christoph Wickert 2011-05-05 09:49:18 EDT
I will revert the change from bug 682444 until we have modular packaging of the themes.
Comment 14 Fedora Update System 2011-05-05 16:00:49 EDT
fedora-icon-theme-1.0.0-10.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/fedora-icon-theme-1.0.0-10.fc15
Comment 15 Fedora Update System 2011-05-05 17:51:27 EDT
Package fedora-icon-theme-1.0.0-10.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedora-icon-theme-1.0.0-10.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/fedora-icon-theme-1.0.0-10.fc15
then log in and leave karma (feedback).
Comment 16 cblaauw 2011-05-06 14:20:19 EDT
With gnome-themes pulled in, the gdm icon for power-off is changed to a colorful computer and does not match to the other gnome 3 icons.
Comment 17 cblaauw 2011-05-06 14:22:53 EDT
I cannot remove fedora-icon-theme, because that would result in erasing gdm as well:

[root@m7 ~]# yum remove fedora-icon-theme
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package fedora-icon-theme.noarch 0:1.0.0-9.fc15 will be erased
--> Processing Dependency: system-icon-theme for package: 1:gdm-3.0.0-2.fc15.x86_64
--> Running transaction check
---> Package gdm.x86_64 1:3.0.0-2.fc15 will be erased
--> Processing Dependency: gdm for package: pulseaudio-gdm-hooks-0.9.22-5.fc15.x86_64
--> Processing Dependency: gdm >= 1:2.22.0 for package: pulseaudio-gdm-hooks-0.9.22-5.fc15.x86_64
--> Running transaction check
---> Package pulseaudio-gdm-hooks.x86_64 0:0.9.22-5.fc15 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================
 Package                           Arch                Version                      Repository                     Size
========================================================================================================================
Removing:
 fedora-icon-theme                 noarch              1.0.0-9.fc15                 @fedora                        19 k
Removing for dependencies:
 gdm                               x86_64              1:3.0.0-2.fc15               @updates-testing              5.8 M
 pulseaudio-gdm-hooks              x86_64              0.9.22-5.fc15                @updates-testing              385  

Transaction Summary
========================================================================================================================
Remove        3 Package(s)

Installed size: 5.8 M
Is this ok [y/N]: n
Exiting on user Command
Complete!
Comment 18 Christoph Wickert 2011-05-06 14:55:16 EDT
(In reply to comment #16)
> With gnome-themes pulled in, the gdm icon for power-off is changed to a
> colorful computer and does not match to the other gnome 3 icons.

This is not fedora-icon-theme's problem I think. This is one more reason to switch to a modular packaging of gnome-themes as I suggested before. For this bug, we have no other option but to require gnome-themes.

(In reply to comment #17)
> I cannot remove fedora-icon-theme, because that would result in erasing gdm as
> well:
> 
> [root@m7 ~]# yum remove fedora-icon-theme
> Loaded plugins: langpacks, presto, refresh-packagekit
> Setting up Remove Process
> Resolving Dependencies
> --> Running transaction check
> ---> Package fedora-icon-theme.noarch 0:1.0.0-9.fc15 will be erased
> --> Processing Dependency: system-icon-theme for package:

system-icon-theme is a virtual provides. Did you try to install another package that provides it first?
Comment 19 cblaauw 2011-05-06 15:11:57 EDT
There's no alternative:

[root@m7 ~]# yum whatprovides system-icon-theme
Loaded plugins: langpacks, presto, refresh-packagekit
fedora-icon-theme-1.0.0-9.fc15.noarch : Fedora icon theme
Repo        : fedora
Matched from:
Other       : system-icon-theme



fedora-icon-theme-1.0.0-10.fc15.noarch : Fedora icon theme
Repo        : updates-testing
Matched from:
Other       : system-icon-theme



fedora-icon-theme-1.0.0-9.fc15.noarch : Fedora icon theme
Repo        : installed
Matched from:
Other       : Provides-match: system-icon-theme

If fedora-icon-theme is not really used for gnome 3, maybe a some gnome 3 package should provide system-icon-theme
Comment 20 Tim Flink 2011-05-06 15:14:31 EDT
Discussed in the 2011-05-06 blocker review meeting. Accepted NTH since this is a criteria-breaking issue in non-blocking desktops (XFCE, LXDE). Hits the following final release criteria [1]:

"All Applications listed in the desktop menus must have icons
which have a consistent appearance and sufficiently high resolution to avoid
appearing blurry"

[1] https://fedoraproject.org/wiki/Fedora_15_Final_Release_Criteria
Comment 21 John T. Folden 2011-05-06 16:12:51 EDT
I also see the issue as described in comment 16 and 17:
> With gnome-themes pulled in, the gdm icon for power-off is changed to a
> colorful computer and does not match to the other gnome 3 icons.

The icon seems to be getting pulled from Mist. 

It looks really out of place and is counter-intuitive. It's not clear what the little computer is supposed to represent where as, previously, it was immediately obvious with the power symbol.
Comment 22 Christoph Wickert 2011-05-06 16:25:26 EDT
If gdm is supposed to use that particular icon it should not have a generic name such as system system-shutdown. It should be system-shutdown-symbolic as part of the gnome-icon-theme-symbolic package. This means we need to file two different bugs, one against gdm and the other against gnome-icon-theme-symbolic.
Comment 23 Fedora Update System 2011-05-08 23:55:06 EDT
fedora-icon-theme-1.0.0-10.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Stijn Hoop 2011-05-09 14:41:26 EDT
In rawhide, I now get a conflict between gnome-themes-standard and gnome-themes due to the reversion of bug 682444, where gnome-themes is only included because of fedora-icon-theme. I guess this is simply a mess? (I don't see a good solution).
Comment 25 Christoph Wickert 2011-05-09 15:03:28 EDT
What kind of conflict? I don't see a Conflicts: in the gnome-themes-standard's spec so I assume it is a file conflict. What files exactly?
Comment 26 Stijn Hoop 2011-05-09 15:50:47 EDT
Apologies, should have pasted the error as well:

yum -y update fedora-icon-theme

[...]

Dependencies Resolved

================================================================================
 Package                 Arch         Version               Repository     Size
================================================================================
Updating:
 fedora-icon-theme       noarch       1.0.0-10.fc15         rawhide        13 k
Installing for dependencies:
 gnome-themes            noarch       2.32.0-5.fc16         rawhide       2.4 M

Transaction Summary
================================================================================

[...]

Transaction Check Error:
  file /usr/share/icons/HighContrast/index.theme from install of gnome-themes-2.32.0-5.fc16.noarch conflicts with file from package gnome-themes-standard-3.0.1-1.fc16.x86_64
  file /usr/share/icons/HighContrastInverse/index.theme from install of gnome-themes-2.32.0-5.fc16.noarch conflicts with file from package gnome-themes-standard-3.0.1-1.fc16.x86_64
  file /usr/share/themes/HighContrast/index.theme from install of gnome-themes-2.32.0-5.fc16.noarch conflicts with file from package gnome-themes-standard-3.0.1-1.fc16.x86_64
  file /usr/share/themes/HighContrastInverse/index.theme from install of gnome-themes-2.32.0-5.fc16.noarch conflicts with file from package gnome-themes-standard-3.0.1-1.fc16.x86_64
  file /usr/share/themes/HighContrast/gtk-2.0/gtkrc from install of gnome-themes-2.32.0-5.fc16.noarch conflicts with file from package gnome-themes-standard-3.0.1-1.fc16.x86_64
  file /usr/share/themes/HighContrastInverse/gtk-2.0/gtkrc from install of gnome-themes-2.32.0-5.fc16.noarch conflicts with file from package gnome-themes-standard-3.0.1-1.fc16.x86_64
  file /usr/share/themes/LowContrast/gtk-2.0/gtkrc from install of gnome-themes-2.32.0-5.fc16.noarch conflicts with file from package gnome-themes-standard-3.0.1-1.fc16.x86_64
Comment 27 Stijn Hoop 2011-05-18 05:54:13 EDT
Conflict does not appear with fedora-icon-theme-1.0.0-11 / gnome-themes-2.32.0-6.

Note You need to log in before you can comment on or make changes to this bug.