Bug 702235 - [abrt] fedpkg-0.5.9.0-1.fc15: urllib2.py:1161:do_open:URLError: <urlopen error [Errno 110] Connection timed out>
Summary: [abrt] fedpkg-0.5.9.0-1.fc15: urllib2.py:1161:do_open:URLError: <urlopen erro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-packager
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:84501e76558d783681f0d42caf0...
: 702445 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-05 06:34 UTC by Alexander Kurtakov
Modified: 2013-01-10 06:36 UTC (History)
4 users (show)

Fixed In Version: fedora-packager-0.5.9.2-1.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-10 13:31:52 UTC


Attachments (Terms of Use)
File: backtrace (1.47 KB, text/plain)
2011-05-05 06:34 UTC, Alexander Kurtakov
no flags Details

Description Alexander Kurtakov 2011-05-05 06:34:27 UTC
abrt version: 2.0.1
comment: I've simply run `fedpkg scratch-build` after waiting a bit fedpkg crashed and the crash has been catched by abrt
package: fedpkg-0.5.9.0-1.fc15
executable: /usr/bin/fedpkg
cmdline: /usr/bin/python /usr/bin/fedpkg scratch-build
component: fedora-packager
kernel: 2.6.38.4-20.fc15.i686
reason: urllib2.py:1161:do_open:URLError: <urlopen error [Errno 110] Connection timed out>
architecture: i686
uid: 500
username: akurtakov
os_release: Fedora release 15 (Lovelock)
time: 1304577106

backtrace
-----
urllib2.py:1161:do_open:URLError: <urlopen error [Errno 110] Connection timed out>

Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 1494, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 675, in scratchbuild
    build(args)
  File "/usr/bin/fedpkg", line 334, in build
    url, chain, arches, sets)
  File "/usr/lib/python2.7/site-packages/pyfedpkg/__init__.py", line 1294, in build
    if urllib2.urlopen(STATUSURL).read():
  File "/usr/lib/python2.7/urllib2.py", line 126, in urlopen
    return _opener.open(url, data, timeout)
  File "/usr/lib/python2.7/urllib2.py", line 392, in open
    response = self._open(req, data)
  File "/usr/lib/python2.7/urllib2.py", line 410, in _open
    '_open', req)
  File "/usr/lib/python2.7/urllib2.py", line 370, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.7/urllib2.py", line 1186, in http_open
    return self.do_open(httplib.HTTPConnection, req)
  File "/usr/lib/python2.7/urllib2.py", line 1161, in do_open
    raise URLError(err)
URLError: <urlopen error [Errno 110] Connection timed out>

Local variables in innermost frame:
err: error(110, 'Connection timed out')
h: <httplib.HTTPConnection instance at 0xa2973ac>
self: <urllib2.HTTPHandler instance at 0xa28ef4c>
req: <urllib2.Request instance at 0xa28eacc>
headers: {'Host': 'jkeating.fedorapeople.org', 'Connection': 'close', 'User-Agent': 'Python-urllib/2.7'}
host: 'jkeating.fedorapeople.org'
http_class: <class httplib.HTTPConnection at 0x9e2574c>

Comment 1 Alexander Kurtakov 2011-05-05 06:34:30 UTC
Created attachment 496989 [details]
File: backtrace

Comment 2 Jesse Keating 2011-05-05 17:47:23 UTC
Yeah, I should catch this error.  Not much I can do about the timeout happening though.

Comment 3 Jesse Keating 2011-05-05 17:48:30 UTC
*** Bug 702445 has been marked as a duplicate of this bug. ***

Comment 4 Jesse Keating 2011-05-23 22:57:12 UTC
Submitted something upstream to fix this.

Comment 5 Fedora Update System 2011-05-28 01:14:16 UTC
fedora-packager-0.5.9.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.9.2-1.fc15

Comment 6 Fedora Update System 2011-05-28 01:20:23 UTC
fedora-packager-0.5.9.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.9.2-1.fc14

Comment 7 Fedora Update System 2011-05-28 01:22:06 UTC
fedora-packager-0.5.9.2-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.9.2-1.fc13

Comment 8 Fedora Update System 2011-05-28 01:26:48 UTC
fedora-packager-0.5.9.2-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.9.2-1.el6

Comment 9 Fedora Update System 2011-05-28 01:28:27 UTC
fedora-packager-0.5.9.2-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/fedora-packager-0.5.9.2-1.el5

Comment 10 Fedora Update System 2011-05-28 21:32:33 UTC
Package fedora-packager-0.5.9.2-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing fedora-packager-0.5.9.2-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/fedora-packager-0.5.9.2-1.el6
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2011-06-10 13:31:19 UTC
fedora-packager-0.5.9.2-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-06-15 05:47:43 UTC
fedora-packager-0.5.9.2-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-06-15 05:52:50 UTC
fedora-packager-0.5.9.2-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2011-06-16 00:29:42 UTC
fedora-packager-0.5.9.2-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2011-06-16 00:32:45 UTC
fedora-packager-0.5.9.2-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.