Bug 702366 - /usr/include/rpc is gone, yet references to it remain
Summary: /usr/include/rpc is gone, yet references to it remain
Keywords:
Status: CLOSED DUPLICATE of bug 702354
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-05 13:11 UTC by Jim Meyering
Modified: 2016-11-24 12:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-05 13:34:51 UTC


Attachments (Terms of Use)

Description Jim Meyering 2011-05-05 13:11:09 UTC
Description of problem: anything that includes netdb.h no longer compiles due to lack of /usr/include/rpc

Version-Release number of selected component (if applicable): glibc-headers-2.13.90-10.x86_64

How reproducible: every time


Steps to Reproduce:
1. echo '#include <netdb.h>' > k.c && gcc -c k.c
2.
3.
  
Actual results:
In file included from k.c:1:0:
/usr/include/netdb.h:33:24: fatal error: rpc/netdb.h: No such file or directory
compilation terminated.

Expected results:
gcc exits with status 0; no diagnostic.

Additional info:

Comment 1 Jim Meyering 2011-05-05 13:18:18 UTC
FYI, quick work-around: cd /usr/include && ln -s gssrpc rpc

Comment 2 Andreas Schwab 2011-05-05 13:34:51 UTC

*** This bug has been marked as a duplicate of bug 702354 ***


Note You need to log in before you can comment on or make changes to this bug.