Bug 702368 - include <nspr4/nspr.h> errors out: "rpc/netdb.h: No such file or directory"
Summary: include <nspr4/nspr.h> errors out: "rpc/netdb.h: No such file or directory"
Keywords:
Status: CLOSED DUPLICATE of bug 702354
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-05 13:20 UTC by Denys Vlasenko
Modified: 2016-11-24 15:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-05 14:04:45 UTC


Attachments (Terms of Use)

Description Denys Vlasenko 2011-05-05 13:20:13 UTC
$ cat z.c

#include <nspr4/nspr.h>
int main() { return 0; }

$ gcc z.c

In file included from /usr/include/nspr4/prinet.h:87:0,
                 from /usr/include/nspr4/nspr.h:49,
                 from z.c:1:
/usr/include/netdb.h:33:24: fatal error: rpc/netdb.h: No such file or directory
compilation terminated.

Comment 1 Denys Vlasenko 2011-05-05 13:27:14 UTC
Possibly a glibc packaging problem.

Looks like /usr/include/rpc/netdb.h has to be provided by glibc-headers, and system thinks that it should be already installed, since glibc-headers is installed.

# yum install /usr/include/rpc/netdb.h
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Package matching glibc-headers-2.13.90-9.i686 already installed. Checking for update.
Nothing to do

But file doesn't exist.

I tried reinstalling glibc-headers, file is still missing.

Comment 2 Denys Vlasenko 2011-05-05 13:53:00 UTC
Simpler reproducer:

#include <netdb.h>
int main() { return 0; }

Since /usr/include/netdb.h is a glibc file, reassigning to glibc.

Comment 3 Andreas Schwab 2011-05-05 14:04:45 UTC

*** This bug has been marked as a duplicate of bug 702354 ***


Note You need to log in before you can comment on or make changes to this bug.