Bug 702472 - iwlagn frequently gets stuck
iwlagn frequently gets stuck
Status: CLOSED DUPLICATE of bug 648732
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-05 14:26 EDT by Bryan O'Sullivan
Modified: 2011-05-25 08:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-25 08:06:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan O'Sullivan 2011-05-05 14:26:30 EDT
Description of problem:

I have a Lenovo X200 with an Intel 5300 wifi chip. When talking on my WPA-secured network (Linksys WRT310N AP), it will work normally for an unpredictable amount of time (a few seconds to a few hours), then get "stuck", such that network traffic fails and existing connections get dropped.

Unfortunately, there's not much info in /var/log/messages to make it very clear what's going on. I'm happy to provide diagnostic info. Also, there is not an obvious event that precipitates the problem: sometimes it happens after a few seconds, other times after hours, with no clear correlation to network activity.

When this hang happens, I can usually kick things into working for another while by running "rmmod iwlagn && modprobe iwlagn", but the laptop will crash after a few of these forced unload/reload cycles.

Version-Release number of selected component (if applicable):

kernel-2.6.35.12-90.fc14.x86_64
iwl5000-firmware-8.83.5.1-2.fc14.noarch
Comment 1 Stanislaw Gruszka 2011-05-09 15:44:08 EDT
These 5xxx devices have troubles with 11n. However situation is somehow now improved in 2.6.39. As you know we are trying to backport some fixes to older kernel that could possibly help to. Also you probably know about workaround to these problems in form of 11n_disable=1 module option.
Comment 2 Stanislaw Gruszka 2011-05-25 08:06:21 EDT

*** This bug has been marked as a duplicate of bug 648732 ***

Note You need to log in before you can comment on or make changes to this bug.