Bug 702549 - shouldn't add "#, fuzzy" to gettext header
shouldn't add "#, fuzzy" to gettext header
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2011-05-06 02:22 EDT by hding
Modified: 2013-03-03 21:21 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.5-SNAPSHOT-20120217-1255
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 19:08:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
original PO (602 bytes, text/x-gettext-translation)
2011-05-06 02:23 EDT, hding
no flags Details
the PO file which is pulled from server (568 bytes, text/x-gettext-translation)
2011-05-06 02:23 EDT, hding
no flags Details

  None (edit)
Description hding 2011-05-06 02:22:20 EDT
Description of problem:
mvn client should preserve PO file Meta data correctly.

Version-Release number of selected component (if applicable):
1.3-alpha-3

How reproducible:

Steps to Reproduce:
1.mvn zanata:publican-push -Dzanata.importPo
2.mvn zanata:publican-pull -Dzanata.dstDir=.

  
Actual results:
PO file Meta data changed

Expected results:
PO file Meta data preserved correctly


Additional info:
please see the attachments
One is original PO file
The other one is the PO file which is pulled from server.
Comment 1 hding 2011-05-06 02:23:08 EDT
Created attachment 497291 [details]
original PO
Comment 2 hding 2011-05-06 02:23:40 EDT
Created attachment 497292 [details]
the PO file which is pulled from server
Comment 3 Sean Flanigan 2011-05-06 02:38:55 EDT
If a text flow is exported, then imported with the same content, a new revision is being created, when in fact the revision shouldn't change.  The new revision has no translator credit because it was imported.
Comment 4 Sean Flanigan 2011-05-25 23:51:47 EDT
Dean, would you please see if you can reproduce this?
Comment 5 Sean Flanigan 2011-05-27 00:04:24 EDT
Having clarified with Helen, the specific bug being reported is:

1. "#, fuzzy" was added to header comment
2. "Test:Zanata" in the header was changed to "Test: Zanata\n"

1. is a mostly cosmetic bug which we should get around to fixing.
2. is okay, because Zanata normalises the name-value pairs in the header (space after colon, newline at end).

Also, we should avoid adding blank "#:" entries to messages.
Comment 6 Ding-Yi Chen 2011-07-11 20:41:04 EDT
Bug reproduced and confirmed with:

Zanata version 1.4-SNAPSHOT (20110712-0601). 

Client: maven client API timestamp is 20110623-1549
Comment 7 Sean Flanigan 2011-09-07 00:32:58 EDT
Assigning to Scrum product owner for prioritisation.
Comment 8 Ding-Yi Chen 2012-02-17 00:52:57 EST
VERIFIED with Zanata maven  client API timestamp is 20120217-1255, but server API timestamp is 20120217-1456

Note You need to log in before you can comment on or make changes to this bug.