Bug 702603 - FormatCreateError: ('format failed: 1', '/dev/mapper/vg_kralik-LogVol01')
Summary: FormatCreateError: ('format failed: 1', '/dev/mapper/vg_kralik-LogVol01')
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 15
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:f58ecefb5f978c269...
Depends On:
Blocks: F15Blocker, F15FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2011-05-06 10:17 UTC by Kamil Páral
Modified: 2011-05-14 04:05 UTC (History)
6 users (show)

Fixed In Version: anaconda-15.31-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-14 04:05:17 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (839.05 KB, text/plain)
2011-05-06 10:18 UTC, Kamil Páral
no flags Details
Attached traceback automatically from anaconda. (612.47 KB, text/plain)
2011-05-06 10:29 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2011-05-06 10:17:56 UTC
The following was filed automatically by anaconda:
anaconda 15.30 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 372, in doFormat
    raise FormatCreateError("format failed: %s" % ret.rc, self.device)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 848, in create
    return self.doFormat(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 428, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 313, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 356, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/pyanaconda/packages.py", line 116, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1257, in nextClicked
    self.anaconda.dispatch.gotoNext()
FormatCreateError: ('format failed: 1', '/dev/mapper/vg_kralik-LogVol01')

Comment 1 Kamil Páral 2011-05-06 10:18:02 UTC
Created attachment 497321 [details]
Attached traceback automatically from anaconda.

Comment 2 Kamil Páral 2011-05-06 10:29:32 UTC
Created attachment 497325 [details]
Attached traceback automatically from anaconda.

Comment 3 Kamil Páral 2011-05-06 10:36:30 UTC
I think this issue is caused by creating btrfs partition. The second report was caused by using default disk layout at first, but shrinking root partition and creating another 100MB btrfs LV partition (mounted at /opt) in the same volume group. Anaconda CCed me again to this bug, so I believe it is also the root cause of the first failure.

In case it is really caused by creating btrfs partition, I'm marking this bug as F15Blocker according to this release criterion:

"5. The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above"
https://fedoraproject.org/wiki/Fedora_15_Final_Release_Criteria

Comment 4 David Lehman 2011-05-06 13:55:59 UTC
From the logs:

Running... mkfs.btrfs /dev/mapper/VolGroup-LogVol02
device /dev/mapper/VolGroup-LogVol02 is too small (must be at least 256 MB)


So the minimum device size for a btrfs filesystem is 256 MB. In the short term, you can just make sure your device is large enough. In the longer term, we can update the minimum for btrfs in anaconda very easily.

Comment 5 James Laska 2011-05-06 13:57:23 UTC
After discussion in #anaconda, it seems the problem here is that the btrfs filesystem has a minimum size of 256M, and anaconda isn't enforcing that minimum partition size.

09:49:02   wwoods: no, there's totally a _minSize attribute for filesystems
09:49:08   wwoods: it's just not set for btrfs
09:49:20   wwoods: dlehman: we talked about this yesterday actually
09:50:05   dlehman: wwoods: yeah, oddly enough
09:50:17   wwoods: minsize is 256MiB, maxsize is 16EiB (1EiB = 1024PiB = 1024*1024TiB = HOOOORJJJ THAT'S A LOT OF DATA)

According to dlehman, support exists for anaconda to enforce this, but the MINSIZE is currently not set.  The fix is a one-liner, and should be reasonable for F15.

While this feels like a documentable edge condition, it certainly is covered by the final criteria "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above "

+1 Blocker, +1 NTH (if needed)

Comment 6 Kamil Páral 2011-05-06 14:06:25 UTC
I can confirm that creating btrfs partition larger than 256MB seems to be working ok.

Comment 7 David Lehman 2011-05-06 16:07:35 UTC
Should be fixed in anaconda-15.31-1.

Comment 8 Tim Flink 2011-05-06 17:22:22 UTC
Discussed in the 2011-05-06 blocker review meeting. Accepted as F15 final blocker under the following criteria:

"The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above "

Comment 9 Fedora Update System 2011-05-06 19:03:36 UTC
anaconda-15.31-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.31-1.fc15

Comment 10 Fedora Update System 2011-05-07 15:04:52 UTC
Package anaconda-15.31-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-15.31-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/anaconda-15.31-1.fc15
then log in and leave karma (feedback).

Comment 11 James Laska 2011-05-10 13:52:32 UTC
VERIFIED this fix using a custom boot.iso built with anaconda-15.31-1.fc15.  Anaconda provides an error dialog noting that the requested size is too small.  The user is able to continue and readjust the partition size as directed.

Comment 12 Fedora Update System 2011-05-14 04:05:02 UTC
anaconda-15.31-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.