Bug 702623 - Problems with caseless reference matching in UTF-8 mode when the upper/lower case characters have different lengths
Summary: Problems with caseless reference matching in UTF-8 mode when the upper/lower ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pcre
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: http://bugs.exim.org/show_bug.cgi?id=...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-06 12:02 UTC by Petr Pisar
Modified: 2011-09-25 03:32 UTC (History)
2 users (show)

Fixed In Version: pcre-8.10-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 703140 (view as bug list)
Environment:
Last Closed: 2011-05-19 04:52:46 UTC
Type: ---


Attachments (Terms of Use)
Fix ported from upstream (16.06 KB, patch)
2011-05-09 11:59 UTC, Petr Pisar
no flags Details | Diff
Fix rebased to pcre-7.8 (12.86 KB, patch)
2011-05-11 11:50 UTC, Petr Pisar
no flags Details | Diff
Missing macros unsuccessfully ported for pcre-7.8 (3.02 KB, patch)
2011-05-11 11:53 UTC, Petr Pisar
no flags Details | Diff

Description Petr Pisar 2011-05-06 12:02:35 UTC
E.g. pcretest input:

/(ȺȺȺ)?\1/8i
    ȺȺȺⱥⱥ

should not match (the thirds lower `ⱥ' is missing) but pcre <= 8.12 states falsely:

 0: \x{23a}\x{23a}\x{23a}\x{2c65}\x{2c65}
 1: \x{23a}\x{23a}\x{23a}

This is fixed in development SVN tree in commits 

r595 | ph10 | 2011-05-02 12:33:29 +0200 (Po, 02 kvě 2011) | 3 lines
Fix problems with caseless reference matching in UTF-8 mode when the 
upper/lower case characters have different lengths.

and 

r597 | ph10 | 2011-05-02 19:08:52 +0200 (Po, 02 kvě 2011) | 2 lines
Complete incomplete fix for UTF-8 caseless references of different lengths.

This bug is tracked by upstream at <http://bugs.exim.org/show_bug.cgi?id=1074>.

All Fedoras affected (pcre-8.12-2.fc15.x86_64 through pcre-7.8-3.fc12.x86_64).

Comment 1 Petr Pisar 2011-05-09 11:59:30 UTC
Created attachment 497774 [details]
Fix ported from upstream

Fix including tests ported from upstream to pcre-8.12.

Comment 2 Petr Pisar 2011-05-09 12:10:23 UTC
Fixed in pcre-8.12-4.fc16.

Comment 3 Fedora Update System 2011-05-09 12:35:45 UTC
pcre-8.12-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/pcre-8.12-3.fc15

Comment 4 Fedora Update System 2011-05-09 13:06:33 UTC
pcre-8.10-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pcre-8.10-2.fc14

Comment 5 Fedora Update System 2011-05-09 20:56:56 UTC
Package pcre-8.10-2.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pcre-8.10-2.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/pcre-8.10-2.fc14
then log in and leave karma (feedback).

Comment 6 Petr Pisar 2011-05-11 11:50:12 UTC
Created attachment 498268 [details]
Fix rebased to pcre-7.8

This is rebase of upstream fix. It does not compile because missing macros.

Comment 7 Petr Pisar 2011-05-11 11:53:01 UTC
Created attachment 498270 [details]
Missing macros unsuccessfully ported for pcre-7.8

This allows to compile pcre-7.8 (F13), reproducer passes, but other important tests fails. Currently there is no fix for F13.

Comment 8 Fedora Update System 2011-05-19 04:52:41 UTC
pcre-8.12-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-09-25 03:32:28 UTC
pcre-8.10-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.