This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 702664 - Umount not possible
Umount not possible
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cifs-utils (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Layton
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 705477
  Show dependency treegraph
 
Reported: 2011-05-06 10:12 EDT by Pavel Alexeev
Modified: 2014-06-18 03:41 EDT (History)
5 users (show)

See Also:
Fixed In Version: cifs-utils-4.9-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 705477 (view as bug list)
Environment:
Last Closed: 2011-05-24 23:02:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2011-05-06 10:12:45 EDT
Description of problem:
[pasha@vbox smolrg]$ mount /mnt/net/y
[pasha@vbox smolrg]$ 
[pasha@vbox mnt]$ umount /mnt/net/y 
umount: /mnt/net/y mount disagrees with the fstab

/etc/fstab related record:
//192.168.100.199/updater /mnt/net/y cifs users,noauto,guest,uid=500,gid=500,file_mode=0666,dir_mode=0777,iocharset=utf8 0 0

I think it is known problem with available patch. Please look at: https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/99437

Version-Release number of selected component (if applicable):
$ rpm -qf `which mount`
util-linux-2.19-4.fc15.i686

How reproducible:
Always.
Comment 1 Karel Zak 2011-05-09 03:33:36 EDT
The problem is that fstab does not match with mtab, right? For example:

fstab:                //foo.com/path
mtab (/proc/mounts):  //foo.com/path/

The umount(8) command (for non-root users) requires that the first field in fstab matches with the first field from mtab (or /proc/mounts).

The mount.cifs should not add the extra '/' to the end of the source path or cifs docs should be updated and the '/' should be required in all fstabs.
Comment 2 Jeff Layton 2011-05-16 07:00:42 EDT
Yep, this was actually fixed in "mainline" cifs-utils a couple of weeks ago by just having it pass the "device" string from userspace to the kernel directly (instead of trying to reconstruct it).
Comment 3 Fedora Update System 2011-05-16 10:20:46 EDT
cifs-utils-4.9-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/cifs-utils-4.9-2.fc15
Comment 4 Pavel Alexeev 2011-05-16 15:11:09 EDT
Could you please post update for Fedora 14 too?
Comment 5 Jeff Layton 2011-05-16 16:46:21 EDT
(In reply to comment #4)
> Could you please post update for Fedora 14 too?

Could you open a bug for this against f14?
Comment 6 Fedora Update System 2011-05-17 01:37:51 EDT
Package cifs-utils-4.9-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cifs-utils-4.9-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/cifs-utils-4.9-2.fc15
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2011-05-24 23:02:31 EDT
cifs-utils-4.9-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.