Bug 702722 - wireless has very poor performance (atheros AR5B97)
wireless has very poor performance (atheros AR5B97)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-06 14:08 EDT by Aaron
Modified: 2012-01-21 16:23 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-21 16:23:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron 2011-05-06 14:08:07 EDT
Description of problem:
Wireless works, but only gets about 20kB/s max for speed, when in windows it gets 200kB/s and above.

Version-Release number of selected component (if applicable):


How reproducible:
without fail every time I reboot and attempt to use wireless.

Steps to Reproduce:
1. Connect to a network
2. open up a web page or 'su -c 'yum update''
3. the speed is slow as you'll see.
  
Actual results:
very slow internet

Expected results:
at least decent speed internet

Additional info:
problem can be fixed by adding: 'options ath9k nohwcrypt=1' to a created file named ath9.conf in /etc/modprobe.d
Comment 1 Kevin Fenzi 2011-05-14 18:09:36 EDT
Proposing we add this to common bugs for f15. 

We have seen a number of folks in #fedora hitting this issue, and the workaround in the first comment ('options ath9k nohwcrypt=1') seems to work around the issue for them.
Comment 2 Aaron 2011-05-14 22:28:44 EDT
we could, I would suggest that the file be added to F15, or just the settings in the kernel changed, whatever works best.
Comment 3 Adam Williamson 2011-05-24 10:50:43 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2011-05-24 10:55:18 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Jesse B 2011-05-26 16:49:59 EDT
Adding 'options ath9k nohwcrypt=1' to /etc/modprobe.d/ath9.conf does not fix this for my system.  After a few minutes, my packet loss rate increases to near 50%, with ping times often as long as 15 seconds.  This is in an area I use frequently, with good reception, and 0% packet loss on the same system booted to Windows.

After upgrading to FC15, this Acer Aspire 5742-6811 / PEW71 system is totally unusable over WiFi, presumably due to the Atheros NIC.
Comment 6 Aaron 2011-05-26 16:53:43 EDT
Jesse,
Sorry I made a mistake in the bug report, if you look here: https://fedoraproject.org/wiki/Bugs/Common#Poor_transfer_speeds_with_Atheros-based_wireless_chipsets its a file called ath9k.conf, I missed the k in my report, I apologize for this.
Comment 7 Adam Williamson 2011-05-26 17:23:28 EDT
you can call the file whatever you want, so long as it ends in .conf ; the system cycles through any and all files in /etc/modprobe.d that end in .conf . So if you used ath9.conf it should still have worked.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Jesse B 2011-05-26 17:28:04 EDT
Thanks so much for your quick response, Aaron.  I renamed
/etc/modprobe.d/ath9.conf to /etc/modprobe.d/ath9k.conf, and restarted the
system.  Unfortunately, within a few minutes, network access again slowed to a
crawl and was losing 75% of the packets when trying to ping my wireless router.
 I have triple-checked the contents of the file.

Please let me know if you have additional suggestions.
Comment 9 Aaron 2011-05-26 17:55:52 EDT
Jesse,
I`m sorry but I cant think of any other alternatives, other than maybe a re-download of the ISO and a re-install, those sometimes help, what wireless driver are you using? the AR5B97? or something else?
Comment 10 Aaron 2011-05-26 17:56:16 EDT
wireless chipset* not driver
Comment 11 Jesse B 2011-05-26 21:56:32 EDT
Not sure of the chipset, but the model is detected by F15 as AR9287.
Comment 12 Jesse B 2011-05-28 04:14:32 EDT
Thoughts on increasing the severity of this bug?  My laptop is now a doorstop under F15, since I don't have convenient access to a wired network.  So many packets are dropped that most network transactions fail.  I have to boot to Windows on my laptop to use it until a fix for this is rolled out.
Comment 13 Paul W 2011-06-12 20:02:17 EDT
I don't know if this is related, but I have an Acer Aspire One with the Atheros AR5001 chipset (168c 001c), and I've been experiencing very bad connection and transfer under F15 (kernel 2.6.38.7-30). Ping showed around 75% packet loss when I did manage to get a connection, and after having made several more attempts and trying to change some settings, I can't connect to my AP at all (WPA2 PSK, hidden SSID)

I've tried a number of suggestions to fix the issue:
 - unloading and reloading the ath5k kernel module
 - Adding pcie_apsm=off to the kernel options
 - creating /etc/modprobe.d/ath5k.conf containing "options ath5k nohwcrypt=1", as per this thread
but all to no avail!
Comment 14 Neil Horman 2011-07-03 19:18:45 EDT
It could be this bug, fixed upstream:
https://bugzilla.kernel.org/show_bug.cgi?id=31452

I've noted some intermittent oddness on my F15 laptop with ath9k, but its always come with poor signal quality at the same time, so I can't be sure.  That patch should apply to the 2.6.35 kernel in F15 without much issue, if someone wants to try it out and confirm or refute this as the fix.
Comment 15 Stanislaw Gruszka 2011-07-07 06:34:34 EDT
I'm maintaining compat wireless packages, to allow to run current upstream wireless drivers on fedora: http://people.redhat.com/sgruszka/compact_wireless.html .
Comment 16 Paul W 2011-07-10 20:16:35 EDT
Hi Stanislaw,

Installed the upstream wireless drivers as suggested - appears to have fixed the issue - I seem have a reliable connection with low ping times again :) Will post any further issues as I test over the next couple of days. Very grateful for your suggestion!

Regards
Paul W
Comment 17 Mitch Davis 2011-10-07 19:45:27 EDT
I'm having the same problem.

My wife's laptop and my laptop are almost identical.  Same brand and model, identical lspci output.  I am running F14, she is running F15.  My Atheros AR9287 WiFi works very well under F14, hers works terribly under F15.

I have tried the hwcrypto workaround, doesn't make any difference.
Comment 18 Mitch Davis 2011-10-09 07:37:03 EDT
(In reply to comment #15)
> I'm maintaining compat wireless packages, to allow to run current upstream
> wireless drivers on fedora:
> http://people.redhat.com/sgruszka/compact_wireless.html .

Hi Stanislaw,

I'd love to try out the compat_wireless, but it seems the F15 package dirs are empty, thus yum install fails.  (Note, this bug is lodged against F15, not F14).  (And as a minor point, I think your page should be called "compat_wireless.html", not "compact_wireless.html".

Thank you for helping us with compat_wireless RPMs!
Comment 19 Stanislaw Gruszka 2011-10-11 10:28:13 EDT
(In reply to comment #18)
> I'd love to try out the compat_wireless, but it seems the F15 package dirs are
> empty, thus yum install fails.  (Note, this bug is lodged against F15, not
> F14).  
Yes, F-15 kernel is 2.6.40 which is renamed 3.0, what is the latest stable compat-wireless release, hence there is no sense to have these compact packages. 

I just updated compat-wireless-next, you might try that.

(And as a minor point, I think your page should be called
> "compat_wireless.html", not "compact_wireless.html".
Thanks. Currently compact_wireless.html is a link to compat_wireless.html.
Comment 20 Mitch Davis 2011-10-13 04:38:10 EDT
(In reply to comment #19)
>
> Yes, F-15 kernel is 2.6.40 which is renamed 3.0, what is the latest stable
> compat-wireless release, hence there is no sense to have these compact
> packages. 
> 
> I just updated compat-wireless-next, you might try that.

I am trying compat-wireless-next, so far I think it's a definite improvement.  Too early to tell whether it's a good fix though, so I'll keep using it for a few days.
Comment 21 Mitch Davis 2011-10-16 07:36:39 EDT
My wife's been trying it out.  For very light duties, it works ok, but for anything involving more than a few seconds of activity (for example, loading GMail), performance becomes terrible.  There is nothing significant in the system log.

What should I do next?

Can you suggest anything I can do to get diagnostic information that will help narrow down where the problem is?
Comment 22 Mitch Davis 2011-10-16 09:00:45 EDT
(In reply to comment #21)
> My wife's been trying it out.

Oh, I should say that "it" is compat-wireless-next.

My /etc/depmod.d/dist.conf is thus:

---- 8< ---------------
#
# depmod.conf
#

# override default search ordering for kmod packaging
search extra updates built-in weak-updates
---- 8< ---------------

And just to make sure I'm loading the right module:

# ifconfig wlan0 down
# rmmod ath9k
# modprobe -n -v ath9k
insmod /lib/modules/2.6.40.6-0.fc15.x86_64/updates/drivers/net/wireless/ath/ath9k/ath9k.ko nohwcrypt=1
# rpm -q -f /lib/modules/2.6.40.6-0.fc15.x86_64/updates/drivers/net/wireless/ath/ath9k/ath9k.ko
kmod-compat-wireless-next-2011_10_10-0.fc15.1.x86_64
Comment 23 Stanislaw Gruszka 2011-10-17 08:17:43 EDT
> Can you suggest anything I can do to get diagnostic information that will help
> narrow down where the problem is?

Since this is upstream driver problem you can report it to Atheros/Qualcomm folks (See ATH9K entry here: http://linuxwireless.org/en/developers/maintainers). If they'll ignore your request, let me know, I'll try to look at that problem more closely.

Also you can always try to solve bug by yourself if this is regression, using bisection. It can be done by compiling kernel sources using git-bisect or by compiling compat-wireless tarballs like described here: 
https://bugzilla.redhat.com/show_bug.cgi?id=716988#c14
Comment 24 Mitch Davis 2011-12-05 08:58:58 EST
(In reply to comment #19)
> (In reply to comment #18)
> > I'd love to try out the compat_wireless, but it seems the F15 package dirs are
> > empty, thus yum install fails.  (Note, this bug is lodged against F15, not
> > F14).  
> Yes, F-15 kernel is 2.6.40 which is renamed 3.0, what is the latest stable
> compat-wireless release, hence there is no sense to have these compact
> packages. 
> 
> I just updated compat-wireless-next, you might try that.

Hello Stanislaw,

Your F15 packages have disappeared, are you able to make them reappear?

Thanks,

Mitch.
> 
> (And as a minor point, I think your page should be called
> > "compat_wireless.html", not "compact_wireless.html".
> Thanks. Currently compact_wireless.html is a link to compat_wireless.html.
Comment 25 Stanislaw Gruszka 2011-12-05 09:34:07 EST
compat-wireless-next seems to be there:

http://people.redhat.com/sgruszka/compat-wireless-next/F-15/

> [DIR] Parent Directory                 -
> [TXT] VERSION-compat-wireless-2011-11-22      28-Nov-2011 05:27       0
> [TXT] VERSION-kernel-2.6.41.1-1.fc15  28-Nov-2011 05:27       0
> [ ]   kmod-compat-wireless-next-2011_11_22-0.fc15.1.i686.rpm  28-Nov-2011 05:23       25M     RPM package file
> [ ]   kmod-compat-wireless-next-2011_11_22-0.fc15.1.x86_64.rpm        28-Nov-2011 05:27       27M     RPM package file
> [ ]   kmod-debug-compat-wireless-next-2011_11_22-0.fc15.1.i686.rpm    28-Nov-2011 05:35       26M     RPM package file
> [ ]   kmod-debug-compat-wireless-next-2011_11_22-0.fc15.1.x86_64.rpm  28-Nov-2011 05:32       28M     RPM package file
> [DIR] repodata/

As told before compat-wireless are not provided as the same wireless bits are already in shipped fedora kernel.
Comment 26 Stanislaw Gruszka 2012-01-21 16:23:07 EST
I believe this bug is fixed.

Note You need to log in before you can comment on or make changes to this bug.