Bug 702740 - Fedora 15 [Regression] - Existing whitelist for pci=bfsort not being preserved
Fedora 15 [Regression] - Existing whitelist for pci=bfsort not being preserved
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
RejectedBlocker, AcceptedNTH
:
Depends On:
Blocks: F15-accepted/F15FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2011-05-06 15:41 EDT by Narendra K
Modified: 2011-05-14 00:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-12 04:49:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Narendra K 2011-05-06 15:41:11 EDT
Description of problem:

The commit 'http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=6e8af08dfa40b747002207d3ce8e8b43a050d99f'

looks for a ‘Dell System’ string to enable pci=bfsort for future Dell systems and does not look for model numbers. But this string matches for older systems such as Dell PowerEdge 2950 and before walking through the already existing white list, the loop breaks resulting in the existing whitelist ignored.


Version-Release number of selected component (if applicable):

kernel version - 2.6.38.5-22.fc15

How reproducible:

Always.


Steps to Reproduce:
1. Install Fedora 15 on a Dell PowerEdge 2950
2. After the installation completes, observe the dmesg. dmesg should show the following message that pci=bfsort is enabled.

PCI: Dell PowerEdge 2950 detected,  enabling pci=bfsort.

Observe that this message is not seen.

  
Actual results: The message indicating that pci=bfsort is enabled is not seen in dmesg.

Expected results: dmesg should show the following message indicating that pci=bfsort is enabled.

PCI: Dell PowerEdge 1950 detected,  enabling pci=bfsort.


Additional info:

This issue is fixed upstream by the following patch -

http://marc.info/?l=linux-pci&m=130046899115205&w=2
http://marc.info/?l=linux-pci&m=130108034729082&w=2
Comment 1 Narendra K 2011-05-06 15:57:11 EDT
Additional info:

The issue is fixed by following patch which is accepted upstream (pending commit) 

http://marc.info/?l=linux-pci&m=130046899115205&w=2
http://marc.info/?l=linux-pci&m=130108034729082&w=2
Comment 2 Tim Flink 2011-05-06 17:49:39 EDT
To summarize:
 * biosdevname is the default method of naming interfaces for F15
 * if biosdevname is disabled, bfsort would be used for interface naming
 * with this issue, network interface names on certain Dell servers would likely 
   not match user expectations coming from previous releases

This was discussed at the 2011-05-06 blocker bug review meeting. Rejected as a blocker as this issue is not covered by any of the release criteria. Accepted as NTH because it could cause problems in network interface naming and cannot be fixed with a post-release update.
Comment 3 Chuck Ebbert 2011-05-07 05:53:22 EDT
(In reply to comment #1)
> The issue is fixed by following patch which is accepted upstream (pending
> commit) 
> 
> http://marc.info/?l=linux-pci&m=130046899115205&w=2
> http://marc.info/?l=linux-pci&m=130108034729082&w=2

You may want to ping Jesse again, because that patch is still not in the PCI git repository.

I added this to F15 and it should make it into the release.
Comment 4 Fedora Update System 2011-05-09 14:27:17 EDT
kernel-2.6.38.6-25.rc1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.6-25.rc1.fc15
Comment 5 Tim Flink 2011-05-09 16:18:23 EDT
Setting this as blocking F15-accepted since it was accepted as NTH and it looks like I missed that when I updated the bug.
Comment 6 Fedora Update System 2011-05-09 18:12:52 EDT
kernel-2.6.38.6-26.rc1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.38.6-26.rc1.fc15
Comment 7 Narendra K 2011-05-12 13:45:23 EDT
(In reply to comment #3)
> (In reply to comment #1)
> > The issue is fixed by following patch which is accepted upstream (pending
> > commit) 
> > 
> > http://marc.info/?l=linux-pci&m=130046899115205&w=2
> > http://marc.info/?l=linux-pci&m=130108034729082&w=2
> 
> You may want to ping Jesse again, because that patch is still not in the PCI
> git repository.
> 
> I added this to F15 and it should make it into the release.

Chuck, Thank you. I will ping Jesse about the inclusion.
Comment 8 Fedora Update System 2011-05-14 00:07:15 EDT
kernel-2.6.38.6-26.rc1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.