Bug 702811 - [abrt] Zim-0.52-1.fc15: pageview.py:2644:email_quote:TypeError: Required argument 'line_number' (pos 1) not found
[abrt] Zim-0.52-1.fc15: pageview.py:2644:email_quote:TypeError: Required argu...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Zim (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Robin Lee
Fedora Extras Quality Assurance
abrt_hash:e750b52f425b9bfecd63915f01b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-07 07:01 EDT by Pierguido Lambri
Modified: 2011-09-28 21:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: Zim-0.53-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-28 21:37:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.02 KB, text/plain)
2011-05-07 07:01 EDT, Pierguido Lambri
no flags Details

  None (edit)
Description Pierguido Lambri 2011-05-07 07:01:30 EDT
abrt version: 2.0.1
architecture: x86_64
executable: /usr/bin/zim
event_log: 2011-05-07-11:52:21> The report was appended to /tmp/abrt.log
component: Zim
reported_to: file: /tmp/abrt.log
cmdline: /usr/bin/python /usr/bin/zim
kernel: 2.6.38.5-22.fc15.x86_64
reason: pageview.py:2644:email_quote:TypeError: Required argument 'line_number' (pos 1) not found
uid: 500
package: Zim-0.52-1.fc15
username: pier
os_release: Fedora release 15 (Lovelock)
time: 1304763508

backtrace
-----
pageview.py:2644:email_quote:TypeError: Required argument 'line_number' (pos 1) not found

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 2433, in do_key_press_event
    if self._do_key_press_event_selection(event):
  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 2651, in _do_key_press_event_selection
    buffer.foreach_line_in_selection(email_quote)
  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 1186, in foreach_line_in_selection
    self.foreach_line(start.get_line(), end.get_line(), func, *args, **kwarg)
  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 1198, in foreach_line
    func(line, *args, **kwarg)
  File "/usr/lib/python2.7/site-packages/zim/gui/pageview.py", line 2644, in email_quote
    iter = buffer.get_iter_at_line()
TypeError: Required argument 'line_number' (pos 1) not found

Local variables in innermost frame:
buffer: <TextBuffer object at 0x1b02730 (zim+gui+pageview+TextBuffer at 0x19b5180)>
line: 3
Comment 1 Pierguido Lambri 2011-05-07 07:01:32 EDT
Created attachment 497514 [details]
File: backtrace
Comment 2 Robin Lee 2011-05-07 08:07:39 EDT
How to reproduce?
Comment 3 Pierguido Lambri 2011-05-08 09:20:03 EDT
I was actually trying to migrate all my notes from Gnote to Zim.
So I started to copy all the content of all the old notes source files (xml files) into Zim (doing the proper adjustement).
I just closed the program Zim and this crash happened.
I'll try to reproduced it again since I still have few notes to move.
Comment 4 Robin Lee 2011-06-09 07:34:57 EDT
Fix committed upstream.
Comment 5 Fedora Update System 2011-09-20 01:13:22 EDT
Zim-0.53-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/Zim-0.53-1.fc15
Comment 6 Fedora Update System 2011-09-20 20:04:21 EDT
Package Zim-0.53-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing Zim-0.53-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/Zim-0.53-1.fc15
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2011-09-28 21:37:20 EDT
Zim-0.53-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.