Bug 702911 - [Ironlake] Screen brightness doesn't work
[Ironlake] Screen brightness doesn't work
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-08 05:37 EDT by Elad Alfassa
Modified: 2013-01-10 09:48 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 09:58:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (105.98 KB, text/plain)
2011-05-08 05:37 EDT, Elad Alfassa
no flags Details
/var/log/messages (619.16 KB, text/plain)
2011-05-08 05:38 EDT, Elad Alfassa
no flags Details
Xorg.0.log (29.59 KB, text/plain)
2011-05-08 05:41 EDT, Elad Alfassa
no flags Details
acpidump (208.60 KB, text/plain)
2011-05-10 12:09 EDT, Elad Alfassa
no flags Details
Comment (241.39 KB, text/plain)
2011-11-09 16:13 EST, Onuralp SEZER
no flags Details

  None (edit)
Description Elad Alfassa 2011-05-08 05:37:36 EDT
Created attachment 497622 [details]
dmesg output

I have a dell inspiron N3010 laptop with an i3 CPU and built in Ironlake display adapter.
Screen brightness doesn't work. gnome displays the OSD for brightness change, but the brightness doesn't actually changes.
Attaching Xorg.0.log, dmesg output and /var/log/messages.
Comment 1 Elad Alfassa 2011-05-08 05:38:21 EDT
Created attachment 497624 [details]
/var/log/messages
Comment 2 Elad Alfassa 2011-05-08 05:41:25 EDT
Created attachment 497629 [details]
Xorg.0.log

If there is any more info needed to debug this, please tell me. It's a really annoying bug, mostly because it shortens the life of my laptop battery.
Comment 3 Elad Alfassa 2011-05-10 11:02:49 EDT
Why [cat:suspend]? It has nothing to do with suspend, as it doesn't work before suspending either.
Comment 4 Adam Jackson 2011-05-10 11:38:51 EDT
Please attach the output of 'ls -lR /sys/class/backlight'.  I suspect the backlight control code is just confused.
Comment 5 Elad Alfassa 2011-05-10 11:45:53 EDT
    /sys/class/backlight/:
    total 0
    lrwxrwxrwx. 1 root root 0 מאי 10 18:43 dell_backlight -> ../../devices/platform/dell-laptop/backlight/dell_backlight
Comment 6 Matthew Garrett 2011-05-10 11:53:42 EDT
Can you please install the pmtools package and attach the output of the acpidump command when run as root, please?
Comment 7 Elad Alfassa 2011-05-10 12:09:29 EDT
Created attachment 498089 [details]
acpidump
Comment 8 Matthew Garrett 2011-05-10 12:26:22 EDT
Looks like this should be using ACPI backlight control but isn't for some reason.
Comment 9 Elad Alfassa 2011-05-11 05:07:17 EDT
Is it possible to force it to use ACPI backlight control (as a workaround)?
Comment 10 Michel Alexandre Salim 2011-06-26 11:03:47 EDT
Try booting with the kernel parameter acpi_backlight=video -- looks like yours default to vendor (which uses, in this case, dell-laptop)
Comment 11 Elad Alfassa 2011-06-26 11:19:55 EDT
(In reply to comment #10)
> Try booting with the kernel parameter acpi_backlight=video -- looks like yours
> default to vendor (which uses, in this case, dell-laptop)
Doesn't work with acpi_backlight=video, whatever I click, (lower or higher brightness) the OSD doesn't change, I think it thinks there is only one level possible...

ls -lR /sys/class/backlight
shows "total 0".



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Jacques Goldberg 2011-07-18 05:33:31 EDT
I have exactly the same problem with the same machine, with FC13 and now with FC14.
I have read somewhere (cannot retrieve) that upgrading the BIOS fixed the problem for somebody.
My BIOS is at version A02 since delivery.
Updating under Windows seems very easy but I only have Linux on my machine.

Can you please check, Elad, your BIOS version? With this command line given as su:      dmidecode | more
you can see the BIOS version near the top of the second page displayed, no need to reboot the machine.

I won't push you into updating your BIOS if you happen to have a double boot wih Windows. The information is on the Dell Web site ; you will need the "service tag" printed on the back of the computer and far easier to read as "serial number" on the line printed by "dmidecode | more" immediately following the BIOS Version. 

Jacques
Comment 13 Elad Alfassa 2011-07-18 06:37:11 EDT
My BIOS version is A11, which is the latest version available from Dell.
Problem still exist.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Josh Boyer 2011-09-27 15:36:06 EDT
Is this issue still present with the 2.6.40.x F15 kernels?
Comment 15 Elad Alfassa 2011-09-28 04:25:25 EDT
(In reply to comment #14)
> Is this issue still present with the 2.6.40.x F15 kernels?
Yes, it is.
Comment 16 Onuralp SEZER 2011-11-01 12:05:52 EDT
I have pavilion dv6 3031-et

Ironlake Intel Graphic and ATI Radeon 5650 ; 

Still Can't I control Brightness with Intel ?
Comment 17 Onuralp SEZER 2011-11-09 16:09:46 EST
(In reply to comment #16)
> I have pavilion dv6 3031-et
> 
> Ironlake Intel Graphic and ATI Radeon 5650 ; 
> 
> Still Can't I control Brightness with Intel ?

Today , I was installed Fedora 16 and I give shot for this brightness problem with Intel but still in bug I think because shortcut key not working also manually with use xbrightness , brightness just change when I wrote to powertop --calibrate  while in calibrating powertop can change manage brightness all levels after that I try to find which file control to brightness level and I found in 

/sys/class/backlight/intel_backlight/brightness 

and I try to change value but system not let me do this. and I was said "fine maybe Xrandr or something else control brightness" and I try to find all control but result is zero ? 

Also I have two cards that can be problem I think, because  I tried to Fedora 16 with different machine model is ; hp dv3 series It have two card too but It was working ?

I really try to find every way in Fedora I searched in Google,fedoraforums,bugzilla etc...

My brightness level 0-10  and my level is 5 in Intel but too high and that level can harm to my eyes. I hope we can find solution

Thank you .

lsmod report ;

Module                  Size  Used by
ppdev                   7360  0 
parport_pc             19600  0 
lp                      9581  0 
parport                32310  3 ppdev,parport_pc,lp
fuse                   61671  3 
vboxpci                13615  0 
vboxnetadp              5558  0 
vboxnetflt             15337  0 
vboxdrv              1806402  3 vboxpci,vboxnetadp,vboxnetflt
8021q                  16999  0 
garp                    6091  1 8021q
stp                     1927  1 garp
llc                     4754  2 garp,stp
fcoe                   18934  0 
rfcomm                 57023  4 
libfcoe                30324  1 fcoe
libfc                  86826  2 fcoe,libfcoe
scsi_transport_fc      42905  2 fcoe,libfc
scsi_tgt               10503  1 scsi_transport_fc
bnep                   14195  2 
ip6t_REJECT             4008  2 
nf_conntrack_ipv6       7714  1 
nf_defrag_ipv6          9115  1 nf_conntrack_ipv6
ip6table_filter         1655  1 
ip6_tables             16776  1 ip6table_filter
nf_conntrack_ipv4       8310  1 
nf_defrag_ipv4          1513  1 nf_conntrack_ipv4
xt_state                1306  2 
nf_conntrack           67597  3 nf_conntrack_ipv6,nf_conntrack_ipv4,xt_state
uvcvideo               56989  0 
videodev               78689  1 uvcvideo
media                  11511  2 uvcvideo,videodev
btusb                  14597  2 
v4l2_compat_ioctl32     7665  1 videodev
bluetooth             202902  23 rfcomm,bnep,btusb
uinput                  7230  0 
snd_hda_codec_hdmi     23548  1 
snd_hda_codec_idt      57630  1 
snd_hda_intel          24072  4 
snd_hda_codec          85181  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep               6264  1 snd_hda_codec
snd_seq                52186  0 
snd_seq_device          5941  1 snd_seq
snd_pcm                78514  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
arc4                    1417  2 
rt2800pci               9507  0 
rt2800lib              39527  1 rt2800pci
crc_ccitt               1557  1 rt2800lib
rt2x00pci               5768  1 rt2800pci
rt2x00lib              46254  3 rt2800pci,rt2800lib,rt2x00pci
mac80211              251598  3 rt2800lib,rt2x00pci,rt2x00lib
snd_timer              19372  2 snd_seq,snd_pcm
i2c_i801                9237  0 
intel_ips              11358  0 
snd                    63124  16 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
cfg80211              151125  2 rt2x00lib,mac80211
soundcore               6267  1 snd
iTCO_wdt               12024  0 
iTCO_vendor_support     2578  1 iTCO_wdt
r8169                  40493  0 
eeprom_93cx6            1647  1 rt2800pci
snd_page_alloc          7311  2 snd_hda_intel,snd_pcm
mii                     4335  1 r8169
hp_wmi                  8103  0 
sparse_keymap           3358  1 hp_wmi
hp_accel               14480  0 
lis3lv02d              11424  1 hp_accel
input_polldev           3382  1 lis3lv02d
rfkill                 16336  5 bluetooth,cfg80211,hp_wmi
microcode              18539  0 
joydev                  9567  0 
wmi                     9033  1 hp_wmi
radeon                691201  0 
ttm                    55029  1 radeon
i915                  389156  9 
drm_kms_helper         26490  2 radeon,i915
drm                   194532  7 radeon,ttm,i915,drm_kms_helper
video                  12388  1 i915
i2c_algo_bit            4958  2 radeon,i915
i2c_core               25728  7 videodev,i2c_i801,radeon,i915,drm_kms_helper,drm,i2c_algo_bit

Smolt report ; 

http://www.smolts.org/client/show/pub_f8e3aacb-d047-4ff0-ad50-b91b2a6ecf1e
Comment 18 Onuralp SEZER 2011-11-09 16:13:44 EST
Created attachment 915377 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 19 Onuralp SEZER 2011-11-14 13:41:19 EST
First I become root in terminal and ; 

I make brightness_intel.sh  

chmod +x brightness_intel.sh

then I add this line ; 
------------------------------
#!/bin/sh

clear

echo "Enter a brightness value"

read brightness

echo $brightness > /sys/class/backlight/intel_backlight/brightness

echo "Brightness set to $brightness."                                    
---------------------------------
And done ..

 I can manage to brightness level this measure too sensitive 

Example :  If I wrote to "1" to brightness that's too low almost see display and I rised to one by one too 150 and that's much better to low level.

I hope that's helped too other people
Comment 20 Josh Boyer 2012-06-06 08:49:42 EDT
Is this still a problem with the 2.6.43/3.3 updates in F15/F16?
Comment 21 Elad Alfassa 2012-06-06 09:20:38 EDT
Can't check F15, but I know it works on F16 and 17, so I guess you can close this bug.
Comment 22 Josh Boyer 2012-06-06 09:58:56 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.