Bug 70293 - RFE: use "initscripts -qc "fsck -T -a /" when checking root filesystem
RFE: use "initscripts -qc "fsck -T -a /" when checking root filesystem
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: initscripts (Show other bugs)
limbo
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 10:56 EDT by petrosyan
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-31 10:58:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2002-07-31 10:56:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
lines 236-238 of /etc/rc.d/rc.sysinit from initscripts-6.88-1 of Limbo2
contain the following lines:
        STRING=$"Checking root filesystem"
	echo $STRING
	initlog -c "fsck -T -a $fsckoptions /"
I would suggest modifying the last line to:
	initlog -qc "fsck -T -a $fsckoptions /"


Version-Release number of selected component (if applicable):
6-88-1


here is the explanation of the "-q" option for initlog:
       -q     Do not print the program's output, unless it exits
              with a non-zero exit code.

Additional info:

So if there are any problems with the root partition the user is gonna see
exactly the same behavior as before.
When there are no errors on the root partition the user is gonna see:

Checking root filesystem                    [   OK   ]

this is how the output looks like now:

Checking root filesystem
fsck: /: clean, 93849/1089152 files, 442599/2175382 blocks  [   OK   ]

I thinks the first looks much better
Comment 1 petrosyan 2002-07-31 10:58:22 EDT
one more thing,

the log files in both cases will look identical

so this is just a cosmetic enhancement
Comment 2 Bill Nottingham 2002-08-13 21:54:20 EDT
I'm fairly sure this will break in-progress reporting of the progress bar for
actual checks.

Note You need to log in before you can comment on or make changes to this bug.