Bug 702934 - dropping ghc-libs confuses yum resolver when installing shared libs
Summary: dropping ghc-libs confuses yum resolver when installing shared libs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ghc
Version: 14
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 705119 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-08 13:31 UTC by Kanak Kshetri
Modified: 2011-05-25 03:13 UTC (History)
5 users (show)

Fixed In Version: ghc-6.12.3-8.6.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-25 03:13:17 UTC


Attachments (Terms of Use)
Full output from yum when installing haskell-platform (99.50 KB, text/plain)
2011-05-08 13:32 UTC, Kanak Kshetri
no flags Details

Description Kanak Kshetri 2011-05-08 13:31:23 UTC
Description of problem:

I cannot currently install haskell-platform because a lot of components are reporting a "Package ghc-libs is obsoleted by ghc, but obsoleting package does not provide for requirements".

yum install --skip-broken haskell-platform causes almost all packages to be skipped.

rpm -Va --nofiles --nodigest had no effect (problem persists even after doing that)

Version-Release number of selected component (if applicable):
0:2010.2.0.0-1

How reproducible:
every time. 

Steps to Reproduce:
1. yum install haskell-platform
2. 
3.
  
Actual results:
Nothing is installed because yum complains that packages are broken.

Expected results:
haskell-platform would be installed.


Additional info:
The output from yum is attached.

Comment 1 Kanak Kshetri 2011-05-08 13:32:06 UTC
Created attachment 497637 [details]
Full output from yum when installing haskell-platform

Comment 2 Jens Petersen 2011-05-09 07:20:08 UTC
Thanks for reporting this.  Looks like some yum "dependency hell" there.
ghc-libs no longer exists since it was split into individual subpackages
for better modularity.  Maybe I need to make ghc-deps.sh generate
explicit requires for binary packages too.

Comment 3 Jens Petersen 2011-05-09 07:28:11 UTC
A workaround seems to be "yum install haskell-platform --exclude=ghc-libs".

Comment 4 Jens Petersen 2011-05-09 09:40:43 UTC
Thanks again for reporting this regression.

I am re-instating the ghc-libs subpackage in f14 in ghc-6.12.3-8.4.fc14
which is building now in Koji, along with a tightening up
of all the subpackage interdependencies.

The build is
http://koji.fedoraproject.org/koji/taskinfo?taskID=3059898
assuming it succeeds. :)

But it will be hard to test the fix until it goes into a yum repo.

Comment 5 Fedora Update System 2011-05-09 10:14:59 UTC
ghc-6.12.3-8.4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ghc-6.12.3-8.4.fc14

Comment 6 Fedora Update System 2011-05-09 20:57:55 UTC
Package ghc-6.12.3-8.4.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ghc-6.12.3-8.4.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ghc-6.12.3-8.4.fc14
then log in and leave karma (feedback).

Comment 7 Jens Petersen 2011-05-10 02:37:55 UTC
Take 2: forgot the "%files ghc-libs", so while ghc-6.12.3-8.4.fc14
"fixes" the problem it is not quite right.

Building a new package http://koji.fedoraproject.org/koji/taskinfo?taskID=3061678
to replace it.

Comment 8 Fedora Update System 2011-05-10 03:47:52 UTC
ghc-6.12.3-8.5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ghc-6.12.3-8.5.fc14

Comment 9 Kanak Kshetri 2011-05-10 15:43:28 UTC
Hi Jens,

I enabled updates-testing and the installation now proceeds without any hitch. Thank you for fixing the bug :)

Comment 10 Fedora Update System 2011-05-10 21:19:21 UTC
Package ghc-6.12.3-8.5.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ghc-6.12.3-8.5.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ghc-6.12.3-8.5.fc14
then log in and leave karma (feedback).

Comment 11 Jens Petersen 2011-05-11 04:05:04 UTC
ghc-6.12.3-8.5.fc14 is better but removing %posttrans scriptlet
in http://koji.fedoraproject.org/koji/taskinfo?taskID=3064667
to avoid install/uninstall error from gen_contents_index.

Comment 12 Jens Petersen 2011-05-11 04:06:08 UTC
(In reply to comment #9)
> I enabled updates-testing and the installation now proceeds without any hitch.
> Thank you for fixing the bug :)

Thanks for testing!

Comment 13 Fedora Update System 2011-05-11 04:40:51 UTC
ghc-6.12.3-8.6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/ghc-6.12.3-8.6.fc14

Comment 14 Fedora Update System 2011-05-13 23:03:06 UTC
Package ghc-6.12.3-8.6.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ghc-6.12.3-8.6.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ghc-6.12.3-8.6.fc14
then log in and leave karma (feedback).

Comment 15 Jens Petersen 2011-05-16 20:47:55 UTC
*** Bug 705119 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2011-05-25 03:13:12 UTC
ghc-6.12.3-8.6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.