Bug 702935 - sound recorder does not work
Summary: sound recorder does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Mashal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-08 13:55 UTC by lionghostshop
Modified: 2013-06-15 05:25 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 883729 (view as bug list)
Environment:
Last Closed: 2013-03-12 08:35:52 UTC
Type: ---


Attachments (Terms of Use)

Description lionghostshop 2011-05-08 13:55:07 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Start gnome-sound-recorder and click record button
  
Actual results:

No recording anything and the system volume control does not have input volume control.

Expected results:
Record sound

Additional info:
Other software requiring input sound works.

Comment 1 Dave Neary 2012-05-25 13:40:25 UTC
I have the same problem on Fedora 17. Skype works fine, and I can see the levels in the "input" tab of the sound settings for the front mic. But sound-recorder just sits there when I hit the record button. It works on Ubuntu 12.04 with GNOME 3 installed.

Comment 2 Jean-François Fortin Tam 2012-06-03 18:53:53 UTC
It was broken for me a few days ago, but seems to work with the gnome 3.4.2 updates now. Can you confirm if that's the case for you too?

Comment 3 Dave Neary 2012-06-04 07:10:31 UTC
Nope - afraid this is still the same. I press the record button, but no recording starts.

I did try to open the volume control from the g-s-c menu, but get the error that "gnome-volume-control is not installed in the path." I believe that's because g-s-c hasn't been updated for GNOME 3 and the new sound preferences yet. So probably unrelated.

Let me see if I can get anything useful out of strace...

Comment 4 Dave Neary 2012-06-04 07:20:22 UTC
When I click on the record button the first time, I see no warnings or errors in the console (when running from command line). However, when I reclick the button, I see "(gnome-sound-recorder:6969): GStreamer-WARNING **: Element 'gconfaudiosource' already has parent".

Could that be related?

Other potential leads: I see that all the devices in /dev/snd have permissions 660 and are owned by root:audio, but my user dneary wasn't in the audio group by default. I've added myself now, and there's no difference, but perhaps there's something else along the lines of permissions I need to look at?

strace output was mostly useless.

Comment 5 Jean-François Fortin Tam 2012-06-04 13:25:18 UTC
I had the same gstreamer warning as you, now I don't anymore. I thought it was the recent round of gnome updates but maybe it's a driver/system issue. Hm.

Comment 6 Dave Neary 2012-06-04 13:41:06 UTC
I just tried running gnome-sound-recorder from the command line as root - recording works.

So it looks like a permissions issue. Now I just need to figure out what exactly I don't have permission to access.

Comment 7 Fedora End Of Life 2012-08-07 15:14:40 UTC
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Dave Neary 2012-08-20 12:59:06 UTC
Hi,

Re-opening (since clearly the person who closed the bug didn't read any of the comments). As I said in comment #1, I am experiencing this with Fedora 17. Seems to be an access issue for something.

Dave.

Comment 9 Fedora Admin XMLRPC Client 2013-02-24 10:42:38 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 10 Fedora Update System 2013-03-04 07:39:57 UTC
gnome-media-3.4.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-media-3.4.0-4.fc18

Comment 11 Fedora Update System 2013-03-04 07:40:16 UTC
gnome-media-3.4.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gnome-media-3.4.0-4.fc17

Comment 12 Fedora Update System 2013-03-04 22:37:31 UTC
Package gnome-media-3.4.0-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-media-3.4.0-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3409/gnome-media-3.4.0-4.fc18
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2013-03-12 08:35:55 UTC
gnome-media-3.4.0-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2013-03-12 08:50:17 UTC
gnome-media-3.4.0-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 D. Charles Pyle 2013-06-15 05:25:21 UTC
The same problem is affecting my machine running Fedora 19 x86_64. Look like either the bug is back or gnome devs got rid of the file.  A search for the file shows the file gnome-volume-control does not exist.  All gnome-media packages and their dependencies are installed.


Note You need to log in before you can comment on or make changes to this bug.