Bug 702963 - [abrt] gnome-session-3.0.1-2.fc15: gvdb_table_lookup: Process /usr/bin/gnome-session was killed by signal 11 (SIGSEGV)
Summary: [abrt] gnome-session-3.0.1-2.fc15: gvdb_table_lookup: Process /usr/bin/gnome-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-session
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e1a49e15abb1670ff9c3de94d7a...
: 704042 (view as bug list)
Depends On:
Blocks: F15Blocker, F15FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2011-05-08 18:07 UTC by Adam Royal
Modified: 2011-05-14 04:08 UTC (History)
5 users (show)

Fixed In Version: dconf-0.7.5-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-14 04:08:33 UTC
Type: ---


Attachments (Terms of Use)
File: event_log (27.63 KB, text/plain)
2011-05-08 18:07 UTC, Adam Royal
no flags Details
File: maps (21.38 KB, text/plain)
2011-05-08 18:07 UTC, Adam Royal
no flags Details
File: backtrace (28.62 KB, text/plain)
2011-05-08 18:07 UTC, Adam Royal
no flags Details

Description Adam Royal 2011-05-08 18:07:53 UTC
abrt version: 2.0.1
architecture:   x86_64
cmdline:        /usr/bin/gnome-session --session gdm --autostart=/usr/share/gdm/autostart/LoginWindow/
component:      gnome-session
crash_function: gvdb_table_lookup
executable:     /usr/bin/gnome-session
kernel:         2.6.38.5-24.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        gnome-session-3.0.1-2.fc15
rating:         4
reason:         Process /usr/bin/gnome-session was killed by signal 11 (SIGSEGV)
time:           Sat May  7 21:26:42 2011
uid:            42
username:       gdm

backtrace:      Text file, 29308 bytes
event_log:      Text file, 28291 bytes
maps:           Text file, 21897 bytes

build_ids:
:4e07b77adb145cc6404542708f22dc48ded94731
:8931ab3c073ffb8513aa5e95e6df924ee22b3691
:1c6a95451ee19617be5abea3d121f0226d21ddda
:aaf7ed41612348bd1141db06cadd428244aa6ea5
:e10b92bc851cfeb7fae30227813f5dc4aeda7d17
:0ba387de3cd9e46c43bef81e2b26bd8d4eea042d
:520b4fb4a57654e299082c3b7e1f3e4498342533
:48b9e02d2199527bf0b51390ce501d804d2e447b
:13ff10a075f084abf260b9dd96618c1037ba3d75
:d0c6e13f00a20952a72a945c929efb175fd760e3
:9cd020ec2107c08febe2c8fcabd158212c207854
:ee2e9edde7fe91da3975e2fd2327293641f5b71b
:0b1f69c75c16ae2ee963cec0721f0e67e2b0f630
:e1818291040433de96fe06cfb1db3776bdbbf88a
:21ad5b8ca30ad4dbb2190cfd19b03c69958ad013
:5dddbb646db3ca0f93a9848c66c8a6dd1b335466
:34fdb31481906f347f8dd8215f0df5d3f074167b
:9ef41f9ca0eabaf3a03dd77eb180e202ab4fe956
:725e19f589592acf6393f26dcac9c10010ba7145
:585e18f56063dab8934660820f0c63765c6c1a1f
:aaf62304b0fc10611d35b4f56005479d4c58868d
:475ee088755895afc66a8ce42a95329f19656eb8
:4953d1f613914126bccceb3cb96386647ffba9df
:0911ea7c180d733724f89037b8e8a34e64024aec
:cdd87cfe38115dcd04c1503689de2a4f5913d6ef
:5c94d34eef463a380dece1eac0811d6cb2dea2f9
:bb12133ef3ea4be2432983db3514ec4720f0487c
:48aea888319e1848137073c9cbde54a4c2a731c9
:e5f626726497a81807681ed0088dbce6d6a1f17b
:2c35820baaea8571d8a8dc977f23cc7f629ddcb4
:4a7e68edf2778a9fbd3d4a8fbd3f9d1e7b785fc6
:0a03e2471dfc65ce2472e1e0dbfd1dc36b8d8c01
:f277cf8af7532168ab476e5f7bddaa44e74ff642
:15916914183cd50af282e6abe89895efe871e694
:4c842320387ff7f6f91b7842b223c16518be909f
:a8891420910aaf776e8bed4280cfa32dfe4243c7
:1dc0dee5d3f9ebc42fbeb7eb4f5527e41127d8fa
:a7158bee1dfaecfbd81d16bc6b31b082b0d5244a
:bdef6ec02819b35976889c12a8adabca9b033a7a
:e735e5cd6423af24f26200f853408dfc063aeea2
:6e43589a53ede420f7bee4ce631efc5414e6752e
:415dd94df0672c555dd4b2a4ef9dbf530694c82c
:91689252818532ec13597b6528d38be93b2706c4
:a594ab36356a9b6dc6ecf25a6124463ccbfd0a29
:f6320d3a9d2dccb9d48d2bf7e87b335f336e4123
:dbb3ab359607f07fa6ef8127b4ea899e29391b96
:c5e3d3ec3b356c2d2ba047a2f03bc0b9d8c03f1a
:d0dd79c27d21227fa6e7478d3f441dbcb6b04173
:1bb5d165bad7c3a7c009196da01f883df3381f62
:74d56d8081dbddfee69a599e8e29c40cddf40af2
:c2d49d72ec1a1e68b39c3724693f83f44d80a259
:1406558950ff100eb0320a325b3ea7961ba1a775
:36a149d1e2c29890b616402f6bc5e3f69ca2738e
:9b3af3c4e04ceb5aaa350786fd48189771cc5d0c
:24af8cb08eb252badc2ea275480b98c3e6a0e280
:79d2d2a3e3d39fcde3bea274434562ecbc41b360
:8164c04fe43680778d29c2775cef453f494ab62b
:df6be855ae1bdee4317721d88037340c1973a319
:9154ac85913d0d23d3aff9e09cc16432b606100b
:77976ba86d7b36b89a8c1d02fbfc8f50986e2d35
:b3900bee00b584ef0bfe2adc2f9b9aed93870bc0

comment:
:Boot.
:This occurs right before gdm should appear, instead the screen flickers and is returned to the command line.

dsos:
:/usr/lib64/libXcursor.so.1.0.2 libXcursor-1.1.11-3.fc15.x86_64 (Fedora Project) 1304798399
:/lib64/libgmodule-2.0.so.0.2800.6 glib2-2.28.6-2.fc15.x86_64 (Fedora Project) 1304797531
:/usr/lib64/libxcb.so.1.1.0 libxcb-1.7-2.fc15.x86_64 (Fedora Project) 1304797544
:/usr/lib64/libXtst.so.6.1.0 libXtst-1.2.0-2.fc15.x86_64 (Fedora Project) 1304798397
:/lib64/libudev.so.0.11.1 libudev-167-4.fc15.x86_64 (Fedora Project) 1304797511
:/usr/lib64/gio/modules/libgioremote-volume-monitor.so gvfs-1.8.1-1.fc15.x86_64 (Fedora Project) 1304798280
:/usr/lib64/libpangoft2-1.0.so.0.2800.4 pango-1.28.4-1.fc15.x86_64 (Fedora Project) 1304798408
:/lib64/libc-2.13.90.so glibc-2.13.90-11.x86_64 (Fedora Project) 1304797497
:/lib64/libresolv-2.13.90.so glibc-2.13.90-11.x86_64 (Fedora Project) 1304797497
:/usr/lib64/libupower-glib.so.1.0.1 upower-0.9.10-1.fc15.x86_64 (Fedora Project) 1304798274
:/lib64/libglib-2.0.so.0.2800.6 glib2-2.28.6-2.fc15.x86_64 (Fedora Project) 1304797531
:/lib64/libutil-2.13.90.so glibc-2.13.90-11.x86_64 (Fedora Project) 1304797497
:/usr/lib64/libSM.so.6.0.1 libSM-1.2.0-2.fc15.x86_64 (Fedora Project) 1304797516
:/usr/lib64/libfontconfig.so.1.4.4 fontconfig-2.8.0-3.fc15.x86_64 (Fedora Project) 1304797840
:/usr/share/locale/en/LC_MESSAGES/gtk30.mo gtk3-3.0.9-1.fc15.x86_64 (Fedora Project) 1304798415
:/lib64/libexpat.so.1.5.2 expat-2.0.1-11.fc15.x86_64 (Fedora Project) 1304797510
:/usr/lib64/libXfixes.so.3.1.0 libXfixes-5.0-1.fc15.x86_64 (Fedora Project) 1304798395
:/usr/lib64/libXrender.so.1.3.0 libXrender-0.9.6-2.fc15.x86_64 (Fedora Project) 1304798395
:/usr/lib64/libX11.so.6.3.0 libX11-1.4.3-1.fc15.x86_64 (Fedora Project) 1304798393
:/usr/lib64/libXinerama.so.1.0.0 libXinerama-1.1.1-2.fc15.x86_64 (Fedora Project) 1304798401
:/usr/lib64/libXdamage.so.1.1.0 libXdamage-1.1.3-2.fc15.x86_64 (Fedora Project) 1304798396
:/lib64/librt-2.13.90.so glibc-2.13.90-11.x86_64 (Fedora Project) 1304797497
:/lib64/libnss_files-2.13.90.so glibc-2.13.90-11.x86_64 (Fedora Project) 1304797497
:/lib64/libgcc_s-4.6.0-20110428.so.1 libgcc-4.6.0-6.fc15.x86_64 (Fedora Project) 1304797411
:/usr/lib64/libxml2.so.2.7.8 libxml2-2.7.8-6.fc15.x86_64 (Fedora Project) 1304797504
:/usr/lib64/libatk-1.0.so.0.9.1 atk-2.0.0-1.fc15.x86_64 (Fedora Project) 1304797533
:/usr/lib64/gio/modules/libdconfsettings.so dconf-0.7.4-1.x86_64 (Fedora Project) 1304797886
:/usr/lib64/gio/modules/libgvfsdbus.so gvfs-1.8.1-1.fc15.x86_64 (Fedora Project) 1304798280
:/lib64/libdbus-1.so.3.5.4 dbus-libs-1:1.4.6-4.fc15.x86_64 (Fedora Project) 1304797501
:/lib64/libgthread-2.0.so.0.2800.6 glib2-2.28.6-2.fc15.x86_64 (Fedora Project) 1304797531
:/usr/lib64/libgdk-3.so.0.0.9 gtk3-3.0.9-1.fc15.x86_64 (Fedora Project) 1304798415
:/lib64/libuuid.so.1.3.0 libuuid-2.19.1-1.fc15.x86_64 (Fedora Project) 1304797515
:/usr/lib64/libgdk_pixbuf-2.0.so.0.2300.3 gdk-pixbuf2-2.23.3-1.fc15.x86_64 (Fedora Project) 1304798394
:/usr/lib64/librsvg-2.so.2.32.1 librsvg2-2.32.1-3.fc15.x86_64 (Fedora Project) 1304798425
:/lib64/libgio-2.0.so.0.2800.6 glib2-2.28.6-2.fc15.x86_64 (Fedora Project) 1304797531
:/usr/lib64/libpangocairo-1.0.so.0.2800.4 pango-1.28.4-1.fc15.x86_64 (Fedora Project) 1304798408
:/usr/bin/gnome-session gnome-session-3.0.1-2.fc15.x86_64 (Fedora Project) 1304798616
:/usr/lib64/libICE.so.6.3.0 libICE-1.0.6-3.fc15.x86_64 (Fedora Project) 1304797505
:/usr/lib64/libcroco-0.6.so.3.0.1 libcroco-0.6.2-6.fc15.x86_64 (Fedora Project) 1304797676
:/usr/lib64/libgtk-3.so.0.0.9 gtk3-3.0.9-1.fc15.x86_64 (Fedora Project) 1304798415
:/usr/lib64/libgvfscommon.so.0.0.0 gvfs-1.8.1-1.fc15.x86_64 (Fedora Project) 1304798280
:/lib64/libpthread-2.13.90.so glibc-2.13.90-11.x86_64 (Fedora Project) 1304797497
:/usr/lib64/libXau.so.6.0.0 libXau-1.0.6-2.fc15.x86_64 (Fedora Project) 1304797543
:/lib64/libdl-2.13.90.so glibc-2.13.90-11.x86_64 (Fedora Project) 1304797497
:/usr/lib64/libpixman-1.so.0.20.2 pixman-0.20.2-2.fc15.x86_64 (Fedora Project) 1304797541
:/usr/lib64/libXrandr.so.2.2.0 libXrandr-1.3.1-2.fc15.x86_64 (Fedora Project) 1304798396
:/lib64/libz.so.1.2.5 zlib-1.2.5-3.fc15.x86_64 (Fedora Project) 1304797501
:/usr/lib64/libXext.so.6.4.0 libXext-1.2.0-2.fc15.x86_64 (Fedora Project) 1304798394
:/lib64/ld-2.13.90.so glibc-2.13.90-11.x86_64 (Fedora Project) 1304797497
:/usr/lib64/libcairo-gobject.so.2.11000.2 cairo-gobject-1.10.2-3.fc15.x86_64 (Fedora Project) 1304798396
:/usr/lib64/libgconf-2.so.4.1.5 GConf2-2.32.3-1.fc15.x86_64 (Fedora Project) 1304797949
:/usr/lib64/libXcomposite.so.1.0.0 libXcomposite-0.4.3-2.fc15.x86_64 (Fedora Project) 1304798397
:/usr/lib64/libpango-1.0.so.0.2800.4 pango-1.28.4-1.fc15.x86_64 (Fedora Project) 1304798408
:/lib64/libgobject-2.0.so.0.2800.6 glib2-2.28.6-2.fc15.x86_64 (Fedora Project) 1304797531
:/usr/lib64/libdbus-glib-1.so.2.1.0 dbus-glib-0.92-2.fc15.x86_64 (Fedora Project) 1304797534
:/usr/lib64/libcairo.so.2.11000.2 cairo-1.10.2-3.fc15.x86_64 (Fedora Project) 1304798396
:/usr/lib64/libORBit-2.so.0.1.0 ORBit2-2.14.19-2.fc15.x86_64 (Fedora Project) 1304797673
:/usr/lib64/libpng12.so.0.44.0 libpng-2:1.2.44-3.fc15.x86_64 (Fedora Project) 1304797502
:/lib64/libselinux.so.1 libselinux-2.0.99-4.fc15.x86_64 (Fedora Project) 1304797525
:/etc/dconf/db/gdm gdm-1:3.0.0-3.fc15.x86_64 (Fedora Project) 1304799314
:/usr/lib64/libXi.so.6.1.0 libXi-1.4.2-1.fc15.x86_64 (Fedora Project) 1304798397
:/usr/lib/locale/locale-archive glibc-common-2.13.90-11.x86_64 (Fedora Project) 1304797488
:/usr/lib64/libfreetype.so.6.6.2 freetype-2.4.4-4.fc15.x86_64 (Fedora Project) 1304797500
:/lib64/libm-2.13.90.so glibc-2.13.90-11.x86_64 (Fedora Project) 1304797497

environ:
:DISPLAY=:0
:DCONF_PROFILE=gdm
:HOME=/var/lib/gdm
:GDM_SEAT_ID=Seat1
:XDG_SESSION_COOKIE=553ff3034d41784f5cb987bc00000018-1304818001.764344-1133959828
:GDM_GREETER_DBUS_ADDRESS=unix:abstract=/tmp/gdm-greeter-yHNHWHKD,guid=2fe91e59696f868a079a275600000024
:GCONF_DEFAULT_SOURCE_PATH=/etc/gconf/2/path
:RUNNING_UNDER_GDM=true
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-iTvg3jI7d1,guid=b034d91f67183feb3ea4532800000025
:GVFS_DISABLE_FUSE=1
:LANG=en_US.UTF-8
:LOGNAME=gdm
:WINDOWPATH=1
:GDM_VERSION=3.0.0
:XAUTHORITY=/var/run/gdm/auth-for-gdm-KSsjr3/database
:USERNAME=gdm
:PWD=/var/lib/gdm
:USER=gdm
:SHELL=/sbin/nologin
:PATH=/usr/local/sbin:/sbin:/usr/sbin:/bin:/usr/bin

Comment 1 Adam Royal 2011-05-08 18:07:55 UTC
Created attachment 497656 [details]
File: event_log

Comment 2 Adam Royal 2011-05-08 18:07:57 UTC
Created attachment 497657 [details]
File: maps

Comment 3 Adam Royal 2011-05-08 18:07:59 UTC
Created attachment 497658 [details]
File: backtrace

Comment 4 Yann Droneaud 2011-05-10 14:39:53 UTC
Package: gnome-session-3.0.1-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
I have run preupgrade from Fedora 14, installation seems to be OK, but after reboot,
the screen flickers and no graphical login screen is shown.

Comment 5 Yann Droneaud 2011-05-10 15:01:25 UTC
I have installed dconf-0.7.5-1 from fedora-testing and it seems to fix the problem.

Comment 6 Yann Droneaud 2011-05-10 15:02:37 UTC
Note, this is a dconf bug which is also reported against others packages, see #702966 and #702964

Comment 7 Adam Royal 2011-05-10 20:41:18 UTC
I can confirm that upgrading to dconf-0.7.5.1 does resolve the problem.

Comment 8 Niki Guldbrand 2011-05-11 19:54:37 UTC
Package: gnome-session-3.0.1-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


Comment
-----
Tried to login with a fresh created user, no previous ${HOME}

Comment 9 Adam Williamson 2011-05-12 17:05:58 UTC
*** Bug 704042 has been marked as a duplicate of this bug. ***

Comment 10 Adam Williamson 2011-05-12 17:07:19 UTC
Transferring blocker nomination from 704042. We have three +1 blocker votes there, so marked this AcceptedBlocker, Alpha criterion "Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied "



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 11 Fedora Update System 2011-05-12 17:09:21 UTC
dconf-0.7.5-1 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/dconf-0.7.5-1

Comment 12 Adam Williamson 2011-05-12 20:09:19 UTC
setting verified as we have multiple reports that this package fixes the issue.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 13 Fedora Update System 2011-05-14 04:08:28 UTC
dconf-0.7.5-1 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.