Bug 703060 - Recent Gnome-shell update caused gnome-shell to crash when Persian (fa) language is selected
Summary: Recent Gnome-shell update caused gnome-shell to crash when Persian (fa) langu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
: 700239 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-09 07:26 UTC by Hedayat Vatankhah
Modified: 2011-05-28 19:01 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-28 19:01:09 UTC


Attachments (Terms of Use)
xsession-error for the gnome-shell crash (3.79 KB, text/plain)
2011-05-09 07:30 UTC, Hedayat Vatankhah
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 650086 None None None Never

Description Hedayat Vatankhah 2011-05-09 07:26:22 UTC
Description of problem:
After recent gnome-shell update, I'm unable to login when fa locale is selected. The contents of xsession-errors is attached. I can login if my locale is US English. 

Version-Release number of selected component (if applicable):
gnome-shell-3.0.1-2.fc15.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Go to system settings and set your language to Persian
2. log out and try to login again
  
Actual results:
Gnome-shell crashes with the attached error messages

Expected results:
Successfull login

Additional info:
In gdm, if I select "Other" instead of a user and write username and password manually, it seems that language selection is ignored and gnome will start in English locale. This way, I can login and change the language back to English.

Comment 1 Hedayat Vatankhah 2011-05-09 07:30:56 UTC
Created attachment 497721 [details]
xsession-error for the gnome-shell crash

Comment 2 Mostafa Daneshvar 2011-05-12 19:08:48 UTC
*** Bug 700239 has been marked as a duplicate of this bug. ***

Comment 3 Hedayat Vatankhah 2011-05-13 07:12:53 UTC
The problem is caused by the Date.toLocaleFormat() function in:
/usr/share/gnome-shell/js/ui/environment.js

If I remove these lines:
//    Date.prototype.toLocaleFormat = function(format) {
//        return Shell.util_format_date(format, this.getTime());
//    };

I can login successfully.

Comment 4 Adam Williamson 2011-05-19 01:01:28 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Adam Williamson 2011-05-24 14:44:42 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 6 Hedayat Vatankhah 2011-05-28 19:01:09 UTC
Fixed in gnome-shell-3.0.2.
Thanks


Note You need to log in before you can comment on or make changes to this bug.