Bug 703063 - [RFE] Update to libpng 1.5.2
Summary: [RFE] Update to libpng 1.5.2
Keywords:
Status: CLOSED DUPLICATE of bug 609234
Alias: None
Product: Fedora
Classification: Fedora
Component: libpng
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-09 07:34 UTC by Jindrich Novy
Modified: 2013-07-03 03:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-14 17:14:45 UTC
Type: ---


Attachments (Terms of Use)

Description Jindrich Novy 2011-05-09 07:34:37 UTC
Description of problem:
Old version of libPNG prevents build of TeX Live 2011 because it uses PNG_FP_1 symbol which is used since 1.5.x and on:

texk/web2c/luatexdir/image/writepng.w:585:19: error: 'PNG_FP_1' undeclared (first use in this function)

Actual results:
Obsolete libpng.

Expected results:
Latest stable libpng

Additional info:
Note that libpng-1.5.2 was released 10th Apr 2011:
http://libpng.sourceforge.net/index.html

Comment 1 Tom Lane 2011-05-09 13:50:45 UTC
1.5 is not stable in my opinion, and even if it was, surely TeX ought to be compilable against libpng versions that are in the wild.  I think this is a TeX bug.

Comment 2 Jindrich Novy 2011-05-13 10:05:03 UTC
Reported this at TeX Live mailing list and it is now fixed in TeX Live upstream:

http://tug.org/pipermail/tex-live/2011-May/029040.html

In any case leaving this bug open as RFE. Thanks.

Comment 3 Tom Lane 2011-07-14 17:14:45 UTC

*** This bug has been marked as a duplicate of bug 609234 ***


Note You need to log in before you can comment on or make changes to this bug.