This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 703112 - Ping-Pong live migration with network load cause guest network down
Ping-Pong live migration with network load cause guest network down
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.7
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Orit Wasserman
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2011-05-09 06:32 EDT by Mike Cao
Modified: 2014-03-03 19:24 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 06:31:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2011-05-09 06:32:23 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Host info:
# uname -r
2.6.18-260.el5
# rpm -q kvm
kvm-83-232.el5

Guest info:
kernel-2.6.32-131.0.13.el6.i686

How reproducible:
sometimes

Steps to Reproduce:
1.Start RHEL6.1 guest on Host t1
eg:/usr/libexec/qemu-kvm -M rhel5.6.0 -m 4G -smp 4,sockets=4,cores=1,threads=1 -name VM -uuid 02b8079c-cca0-ae65-c63a-b2aa4119497d -monitor stdio -no-kvm-pit-reinjection -usbdevice tablet -startdate now -boot c -drive file=/dev/migrate/mike_rhel6U1,if=virtio,format=qcow2,werror=stop,cache=none,boot=on -net nic,macaddr=54:52:40:3d:4c:58,vlan=0,model=virtio -net tap,script=/etc/qemu-ifup,downscript=no,vlan=0 -usb -spice ic=on,host=0,port=5910,disable-ticketing -qxl 1 -k en-us -balloon virtio -notify all
2.Start listenning port on Host t2
3.start #netserver on host t1
4.in the guest ,start 10 netperf client
ip=t1
i=0
for ((i=0;i<10;i++))
do
netperf -H $ip -l 3000 &
echo finish test_No. $i
done
5.do ping-pong live migration between 2 hosts
  
Actual results:
guest network down.
#dmesg in the guest
net eth0:Unexpected full queue
net eth0:Unexpected full queue
net eth0:Unexpected full queue
net eth0:Unexpected full queue
net eth0:Unexpected full queue
net eth0:Unexpected full queue

Expected results:


Additional info:
#service Network restart in the guest ,still can not get ipaddress
Comment 2 Mike Cao 2011-05-09 22:28:06 EDT
Tried start 10 netperf client in the guest w/o migration ,guest's network works
fine.
Comment 4 Mike Cao 2011-05-25 03:45:05 EDT
Tried RHEL5.7 32 bit guest (kernel 2.8.18-262.el5PAE) on kvm-83-235.el5

Hit the same issue.
Comment 8 Ronen Hod 2011-09-12 10:39:29 EDT
Hi Mike,

Since this is not reported by a customer, and we are very aggressive with closing RHEL5.8 bugs, and this looks like yet another high-load problem in RHEL5, I would close it.
Otherwise, mst had some questions in the previous comments.
Do you know if this problem exists in 6.2?
Comment 9 Mike Cao 2011-09-15 03:44:58 EDT
Hi,juzhang

Could you share the migration test results for RHEL6.2 whether hit this issue ?

Best Regards,
Mike
Comment 10 juzhang 2011-09-15 04:15:21 EDT
(In reply to comment #9)
> Hi,juzhang
> 
> Could you share the migration test results for RHEL6.2 whether hit this issue ?
> 
> Best Regards,
> Mike

Didn't hit this issue on rhel6.2.
Comment 13 RHEL Product and Program Management 2012-04-02 06:45:45 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Note You need to log in before you can comment on or make changes to this bug.