Bug 703165 - 2.6.38.5-23 kernel oops (on F14)
Summary: 2.6.38.5-23 kernel oops (on F14)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-09 14:10 UTC by gene c
Modified: 2011-10-12 09:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-23 20:34:14 UTC
Type: ---


Attachments (Terms of Use)
/var/log/messages (7.41 KB, text/plain)
2011-05-09 14:10 UTC, gene c
no flags Details
/var/log/messages (7.41 KB, text/plain)
2011-05-09 17:19 UTC, gene c
no flags Details
lspci.txt (2.44 KB, text/plain)
2011-05-09 19:44 UTC, gene c
no flags Details

Description gene c 2011-05-09 14:10:53 UTC
Created attachment 497799 [details]
/var/log/messages

Description of problem: kernel NULL deref prob (see attached for details)
kernel NULL pointer dereference.
nouveau problem ?

This was compiled from koji source RPM.


Version-Release number of selected component (if applicable):
kernel  2.6.38.5-23
on x86_64




How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 gene c 2011-05-09 17:19:54 UTC
Created attachment 497874 [details]
/var/log/messages

changed to text plain

Comment 2 gene c 2011-05-09 17:48:01 UTC
Forgot to say - the symptoms (from a user perspective) - hesitation - nothing responding followed by black screen (i think) and then return to gdm login screen

Comment 3 gene c 2011-05-09 19:43:17 UTC
Machine is lenovo t61p - attaching lspci

Comment 4 gene c 2011-05-09 19:44:14 UTC
Created attachment 497903 [details]
lspci.txt

Comment 5 gene c 2011-05-09 20:05:45 UTC
output of scripta/ver_linux:


Linux lap1.prv.sapience.com 2.6.38.5-23.fc14.x86_64 #1 SMP Thu May 5 23:06:21 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux
 
Gnu C                  4.5.1
Gnu make               3.82
binutils               2.20.51.0.7
util-linux             2.18
mount                  support
module-init-tools      3.11.1
e2fsprogs              1.41.12
jfsutils               1.1.13
xfsprogs               3.1.2
pcmciautils            017
quota-tools            3.17.
PPP                    2.4.5
isdn4k-utils           3.13
Linux C Library        2.13
Dynamic linker (ldd)   2.13
Procps                 3.2.8
Net-tools              1.60
Kbd                    1.15
oprofile               0.9.6
Sh-utils               8.5
wireless-tools         29
Modules Loaded         tcp_lp hidp fuse rfcomm sco bnep l2cap vboxnetadp vboxnetflt vboxdrv sunrpc cpufreq_ondemand acpi_cpufreq freq_table mperf capi capifs kernelcapi ipt_MASQUERADE iptable_nat nf_nat iptable_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables ipv6 kvm_intel kvm uinput snd_hda_codec_analog snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device arc4 snd_pcm iwlagn r852 sm_common nand nand_ids e1000e i2c_i801 btusb nand_ecc mtd iTCO_wdt iTCO_vendor_support snd_timer iwlcore thinkpad_acpi bluetooth snd wmi microcode mac80211 cfg80211 rfkill joydev soundcore snd_page_alloc xts gf128mul dm_crypt sdhci_pci sdhci firewire_ohci mmc_core firewire_core yenta_socket crc_itu_t nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core video

Comment 6 Niels de Vos 2011-05-31 20:36:46 UTC
I'm not sure if this is a pure nouveau issue. The attached /var/log/messages seem to show the output of a sysrq-m which can indicate that an OOM occurred. If this is the case, the system was Out-Of-Memory before nouveau caused the BUG.

It is not good that nouveau hits a NULL-pointer dereference, there might need to be an extra check for a kmalloc() or similar. But maybe nouveau assumes that allocating some memory or structures just work, and only hits this BUG when the system does not have any memory free anymore.

Comment #2 could describe an out-of-memory issue as well. Killing the GDM session and restarting/reloading Xorg will likely reset the display (and associated nouveau driver).

Did this problem happen more than once? When yes, can you provide a /var/log/messages that contain some more details from before the BUG?

Comment 7 gene c 2011-05-31 20:49:15 UTC
It happened once - if I remember correctly it was starting virtualbox - which may have caused an OOM ... I have not seen it since then - and have also moved to a newer kernel - i'll play some more and see if I can trigger it with the newer kernels.

Comment 8 Josh Boyer 2011-08-23 20:34:14 UTC
We're not using 2.6.38 on any release any more, and certainly never on f14.  I'm going to close this bug out.  If you're still seeing it on a newer release, please open a new bug.

Comment 9 Frank Mehnert 2011-10-12 09:44:48 UTC
Which version of VirtualBox did you use at this time?


Note You need to log in before you can comment on or make changes to this bug.