Bug 703234 - bird not enabled after F14->F15 upgrade
bird not enabled after F14->F15 upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bird (Show other bugs)
15
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Görig
Fedora Extras Quality Assurance
RejectedNTH https://fedoraproject.org...
: CommonBugs
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-09 13:14 EDT by James Laska
Modified: 2013-09-02 02:56 EDT (History)
4 users (show)

See Also:
Fixed In Version: bird-1.3.1-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 00:53:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2011-05-09 13:14:28 EDT
As the  states, bird is enabled and starts on boot in Fedora 14.  After upgrading to Fedora 15, bird is no longer enabled by default, and does not start on boot.  \n\nWhile the workaround is straight forward, I am proposing this as a NTH fix for F15 since this will likely impact F14->F15 users, and it's not obvious that the service isn't running.
Comment 1 Adam Williamson 2011-05-09 15:14:19 EDT
Not on the DVD, so there's nothing to be gained by making this NTH, I don't think. -1.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 James Laska 2011-05-09 15:49:27 EDT
(In reply to comment #1)
> Not on the DVD, so there's nothing to be gained by making this NTH, I don't
> think. -1.

I wasn't able to cross-reference the bugs with what packages are available on
the DVD.  Given that this isn't provided on the DVD, I'm in perfect agreement
that this can easily be addressed by a post-release update and does not affect
the installation media in any way.  

We should however document this issue, as manual intervention will be required to ensure that the service is enabled after upgrade.  Adding CommonBugs keyword

Adding whiteboard:RejectedNTH
Comment 3 Adam Williamson 2011-05-10 14:58:20 EDT
you also have to drop the blocks: f15-accepted when rejecting.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Fedora Update System 2011-05-11 13:27:10 EDT
bird-1.3.1-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/bird-1.3.1-2.fc15
Comment 5 Fedora Update System 2011-05-13 23:06:09 EDT
Package bird-1.3.1-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bird-1.3.1-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/bird-1.3.1-2.fc15
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-05-19 00:53:27 EDT
bird-1.3.1-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 James Laska 2011-05-24 09:25:56 EDT
I documented this issue as a CommonBug.  Please feel free to adjust/patch as needed.

https://fedoraproject.org/wiki/Common_F15_bugs#upgrade-disabled-services

Note You need to log in before you can comment on or make changes to this bug.