Bug 703286 - Compliance Status date is off
Compliance Status date is off
Status: CLOSED DUPLICATE of bug 699442
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.2
Assigned To: Devan Goodwin
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-05-09 16:34 EDT by J.C. Molet
Modified: 2011-08-08 08:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-08 08:50:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dates (340.84 KB, image/png)
2011-05-09 16:34 EDT, J.C. Molet
no flags Details

  None (edit)
Description J.C. Molet 2011-05-09 16:34:19 EDT
Created attachment 497909 [details]
dates

Description of problem:
This is a partial clone of 699442, see https://bugzilla.redhat.com/show_bug.cgi?id=699442#c6

The certificate status is a couple of days off from the actual end date.

Steps to Reproduce:
1. Set up a box with subscription-manager-gui
2. Install one product in your /etc/pki/product
3. Subscribe to the pool that covers that product
4. Look at your compliance status (see screenshot)
  
Actual results:
The compliance status is a couple of days off.

Expected results:
The compliance status date has some connection to reality.
Comment 1 Chris Duryee 2011-05-23 10:55:47 EDT
Altering this requires invasive changes that would likely create other bugs in the cert logic. Moving out to 6.2.
Comment 3 Devan Goodwin 2011-08-03 11:32:24 EDT
Is this still reproducible? I can't get it to happen here, and digging through the code everything looks to be in order. The compliance notice should display last cert end date + 1 day. Everything seems to be using GMT as far as I can tell, at least if the cert is specifying GMT. 

Tested with various timezones, jumping around to different hours around midnight, can't get it to do the above. My Subs tab still shows me July 31 in my case, and the compliance notice says "until" Aug 1.
Comment 4 J.C. Molet 2011-08-08 08:50:39 EDT
I believe this was fixed in 699442, marking a duplicate.

*** This bug has been marked as a duplicate of bug 699442 ***

Note You need to log in before you can comment on or make changes to this bug.