Bug 70340 - Shift plus Tab complete doesn't work
Shift plus Tab complete doesn't work
Status: CLOSED WORKSFORME
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-terminal (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-31 14:08 EDT by Forrest
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-29 14:35:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Forrest 2002-07-31 14:08:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020515

Description of problem:
When I hold down the Shift key, using Tab for tab completion does not work. 
This worked in the previous beta, and in previous versions of GNOME.

Oftimes I hold down the shift key as I am trying to use tab completion
(especially in the Red Hat CD tree).  Typing `cd RedHat/R<TAB>` used to work
while continuing to hold down the shift key.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to use tab complete while holding down the shift key.

Actual Results:  Tab complete doesn't work until you let go of the shift key.
Comment 1 Nalin Dahyabhai 2002-08-14 03:25:56 EDT
The terminal widget maps a shift+tab key to the backtab keysym (\e[Z), which is
consistent with XTerm and makes more sense to me.  I'd be inclined to close this
as either NOTABUG or WONTFIX.
Comment 2 Forrest 2002-08-22 16:14:53 EDT
Is the backtab keysym actually used for anything (in an term)?
Where does one change the map?
Comment 3 Nalin Dahyabhai 2002-08-27 22:21:19 EDT
I couldn't say what an application might use the backtab key for, but I was
mistaken when I stated that it was consistent with xterm.  I'm not sure how you
enter the backtab key in xterm, because there's no capability defined for that
key.  (When you press shift+tab in xterm, it echoes the control sequence for
move-to-previous-backstop, but that's not a key sequence.)

In GTK+ apps, shift-tab generates GDK_ISO_Tab key events, which VTE isn't
actually handling (will be fixed in 0.8.10).  Once VTE starts handling it, the
binding can be overridden by editing /usr/share/vte/termcaps/xterm and adding or
replacing the string specified as the value for "kB".  The default value is \E^I
(escape-tab), which is the same sequence alt-tab produces if your window manager
or application doesn't do something else with it.
Comment 4 Jay Turner 2002-08-28 16:22:18 EDT
I'm not seeing the backtab behavior in a gnome-terminal with vte-0.8.10-1.
Comment 5 Nalin Dahyabhai 2002-08-29 14:35:41 EDT
Jay, to verify, can you run "od -tx1", type in Ctrl-V, Shift-Tab, Enter, Ctrl-D,
and check the output?  You should get "1b 09 0a", which is escape, tab, newline.
Comment 6 Nalin Dahyabhai 2002-10-17 20:49:36 EDT
Closing, works for me.

Note You need to log in before you can comment on or make changes to this bug.