Bug 703531 - Administration tools are listed twice (under both System and Settings) after "fix" for #701693
Summary: Administration tools are listed twice (under both System and Settings) after ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F15Blocker-kde
TreeView+ depends on / blocked
 
Reported: 2011-05-10 15:33 UTC by Kevin Kofler
Modified: 2011-05-14 04:04 UTC (History)
10 users (show)

Fixed In Version: kdelibs-4.6.2-5.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-14 04:04:03 UTC
Type: ---


Attachments (Terms of Use)

Description Kevin Kofler 2011-05-10 15:33:44 UTC
Description of problem:
We dropped the Fedora menu patch in kdelibs-4.6.2-4.fc15 (see bug #701693). Unfortunately, several .desktop files in Fedora have both System and Settings set as categories, which makes them show up twice now.

Version-Release number of selected component (if applicable):
kdelibs-4.6.2-4.fc15

How reproducible:
Always

Steps to Reproduce:
1. Look at the KDE Plasma menu (Kickoff or Classic).
  
Actual results:
Several items listed twice.

Expected results:
Items listed only once.

Additional info:
We need to revert the "fix" for bug #701693, i.e. apply the Fedora menu patch again.

Instead, to fix bug #701693 properly, we need to add Requires: redhat-menus to kdelibs.

Comment 1 Kevin Kofler 2011-05-10 15:49:14 UTC
I'm nominating this as a blocker per the "no duplicates in the menu" release criterion. If it's not considered a blocker, I'd like it to get considered NTH, at least.

Rationale:
* We're normally not enforcing this criterion for KDE, but here an entire menu's worth is duplicated, which looks really bad.
* The fix for this consists of the following 2 changes:
1. We're reapplying a patch (to the menu XML only) which has been applied during the whole F15 development cycle except for the last couple days.
2. We're adding a dependency on redhat-menus, which is a small package and will not lead to spin size issues.
* The fix is being built as we speak.

Comment 2 Kevin Kofler 2011-05-10 15:55:23 UTC
The build we'd want in GA is kdelibs-4.6.2-5.fc15. (The 4.6.3 builds are for 0-day updates.)

Comment 3 Kevin Kofler 2011-05-10 15:58:22 UTC
See both bug #701693 and bug #697834 for related discussion.

Comment 4 Adam Williamson 2011-05-10 16:45:16 UTC
+1 blocker. Please submit kdelibs-4.6.2-5.fc15 as an update, please *don't* submit any later build as an update yet (it'd screw things up for pulling in the build we want).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 5 Fedora Update System 2011-05-10 16:47:27 UTC
kdelibs-4.6.2-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kdelibs-4.6.2-5.fc15

Comment 6 nucleo 2011-05-10 17:55:37 UTC
I think that the real fix for this bug will be when all of system-cofig-* applications will be fixed to be shown only in "Settings".
If this is not possible in F15 maybe should be done in F16 (and then remove "Administration").

Comment 7 Rex Dieter 2011-05-10 18:02:53 UTC
agreed (I'm of a mind to go ahead and conditionalize this change/patch for < f16 now that you mention it)

Comment 8 Adam Williamson 2011-05-10 18:34:17 UTC
it's kind of tricky, because there's a legitimate distinction being drawn here: 'system preferences' - things that are going to apply system-wide - versus 'personal preferences' - things that apply only to your account.

System+Settings=system preferences is a Fedora-ism, not really accounted for in the upstream spec, and that's bad. However, the upstream spec doesn't really provide a good way to draw this (valuable) distinction; there's no two top-level categories that map to it, and no sub-categories of Settings that draw the distinction either.

It's one of those situations where all the options suck, besides perhaps getting the upstream categories updated.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 9 Adam Williamson 2011-05-10 18:55:09 UTC
this doesn't need to block f15blocker directly, since it goes through the kde tracker too (just for cleanliness)



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 10 Kevin Kofler 2011-05-10 19:21:18 UTC
OK, I just wanted to be sure you folks don't miss it. :-)

The funny thing about that system vs. personal preferences distinction is that both KDE Plasma 4 and GNOME 3 are putting mostly personal preferences in an application called "System Settings" in the menu. (That's also why it was so confusing when the "Administration" category accidentally ended up being called "System Settings" in Kickoff.)

Comment 11 nucleo 2011-05-10 20:03:40 UTC
(In reply to comment #8)
> It's one of those situations where all the options suck, besides perhaps
> getting the upstream categories updated.

You mean that "Administration" should be added in upstream?

Or maybe "Settings" should be updated to place there applications which have both categories System and Settings?

Now we have almost empty "Settings" (only "Qt4 Config" there).

Comment 12 Kevin Kofler 2011-05-10 20:14:36 UTC
> (In reply to comment #8)
> > It's one of those situations where all the options suck, besides perhaps
> > getting the upstream categories updated.
>
> You mean that "Administration" should be added in upstream?

I think "upstream" in comment #8 actually refers to the freedesktop.org specification, i.e. that Adam is actually trying to say that the specification needs a new primary category for that purpose.

Comment 13 Fedora Update System 2011-05-14 04:03:53 UTC
kdelibs-4.6.2-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.