Bug 703532 - im-chooser Version mismatch Unable to communicate to IMSettings services
Summary: im-chooser Version mismatch Unable to communicate to IMSettings services
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: im-chooser
Version: 15
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-10 15:35 UTC by wengxufeng
Modified: 2013-10-24 07:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-07 09:46:55 UTC
Type: ---


Attachments (Terms of Use)

Description wengxufeng 2011-05-10 15:35:39 UTC
[root@afon-fedora ~]# im-chooser
Gtk-Message: Failed to load module "pk-gtk-module"

(im-chooser:8275): IMSettings-WARNING **: Error calling StartServiceByName for com.redhat.imsettings: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/libexec/imsettings-daemon exited with status 127

(im-chooser:8275): GLib-GIO-CRITICAL **: g_dbus_proxy_call_sync: assertion `G_IS_DBUS_PROXY (proxy)' failed

(im-chooser:8275): IMSettings-WARNING **: Error calling StartServiceByName for com.redhat.imsettings: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/libexec/imsettings-daemon exited with status 127

(im-chooser:8275): GLib-GIO-CRITICAL **: g_dbus_proxy_get_connection: assertion `G_IS_DBUS_PROXY (proxy)' failed

(im-chooser:8275): GLib-GIO-CRITICAL **: g_dbus_connection_emit_signal: assertion `G_IS_DBUS_CONNECTION (connection)' failed

(im-chooser:8275): IMSettings-WARNING **: Error calling StartServiceByName for com.redhat.imsettings: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/libexec/imsettings-daemon exited with status 127

(im-chooser:8275): GLib-GIO-CRITICAL **: g_dbus_proxy_call_sync: assertion `G_IS_DBUS_PROXY (proxy)' failed
----------------------------------------------
Packages:
im-chooser-1.4.2-1.fc15.x86_64
im-chooser-gnome3-1.4.2-1.fc15.x86_64
imsettings-qt-1.2.2-1.fc15.x86_64
imsettings-1.2.2-1.fc15.x86_64
imsettings-gnome-1.2.2-1.fc15.x86_64
imsettings-libs-1.2.2-1.fc15.x86_64
imsettings-devel-1.2.2-1.fc15.x86_64

Comment 1 Akira TAGOH 2011-05-11 01:16:00 UTC
Assuming you've updated from the older version of imsettings, you have to restart the desktop at least. once you restart your desktop and you don't see this issue again, this is not a bug at all.

Comment 2 wengxufeng 2011-05-11 01:26:25 UTC
(In reply to comment #1)
> Assuming you've updated from the older version of imsettings, you have to
> restart the desktop at least. once you restart your desktop and you don't see
> this issue again, this is not a bug at all.

I have already rebooted my computer many times.
It doesn't work.

Comment 3 Akira TAGOH 2011-05-11 02:05:00 UTC
Can you attach your $HOME/.imsettings.log?

Comment 4 wengxufeng 2011-05-11 02:24:03 UTC
Sorry, I can't access my computer now.

(In reply to comment #3)
> Can you attach your $HOME/.imsettings.log?

Comment 5 wengxufeng 2011-05-11 12:27:22 UTC
Here is my ./imsettings.log.

imsettings information
==========================
Is DBus enabled: yes
Is imsettings enabled: yes
Is GTK+ supported: no
Is Qt supported: no
DESKTOP_SESSION: gnome
DISABLE_IMSETTINGS: 
IMSETTINGS_DISABLE_DESKTOP_CHECK: 
DBUS_SESSION_BUS_ADDRESS: unix:abstract=/tmp/dbus-IzKEOzUsuT,guid=ff5fdf9a6d3c9ffd4aa675e9000000c6
GTK_IM_MODULE: ibus
QT_IM_MODULE: xim
XMODIFIERS: @im=ibus
IMSETTINGS_MODULE: IBus
IMSETTINGS_INTEGRATE_DESKTOP: yes


(In reply to comment #3)
> Can you attach your $HOME/.imsettings.log?

Comment 6 Akira TAGOH 2011-05-12 01:51:34 UTC
Ok, I guess you don't have imsettings-daemon running. what if you run "/usr/libexec/imsettings-daemon --replace" on the terminal and run im-chooser say?

"Version mismatch" would be the side effect of failing an access through DBus. it looks weird to me since your desktop certainly is running under the dbus session.

Comment 7 wengxufeng 2011-05-12 12:37:09 UTC
I get this error when I run "/usr/libexec/imsettings-daemon --replace" .

/usr/libexec/imsettings-daemon: symbol lookup error: /usr/lib64/libnotify.so.4: undefined symbol: gdk_screen_make_display_name

Is there any way to make the desktop not run under the dbus session ? 

(In reply to comment #6)
> Ok, I guess you don't have imsettings-daemon running. what if you run
> "/usr/libexec/imsettings-daemon --replace" on the terminal and run im-chooser
> say?
> 
> "Version mismatch" would be the side effect of failing an access through DBus.
> it looks weird to me since your desktop certainly is running under the dbus
> session.

Comment 8 Akira TAGOH 2011-05-12 12:49:40 UTC
(In reply to comment #7)
> I get this error when I run "/usr/libexec/imsettings-daemon --replace" .
> 
> /usr/libexec/imsettings-daemon: symbol lookup error: /usr/lib64/libnotify.so.4:
> undefined symbol: gdk_screen_make_display_name

That looks like you broke gtk+. if you have any libraries self-built on /usr/local or such, remove it. otherwise reinstall gtk+.

> Is there any way to make the desktop not run under the dbus session ? 

Nope.

Comment 9 Akira TAGOH 2011-05-30 10:07:54 UTC
Ping?

Comment 10 Akira TAGOH 2011-06-07 09:46:55 UTC
guess you've got resolved this issue with the above. closing this so far. please reopen if you still see this.

Comment 11 Ivan Lyon 2013-10-24 03:36:45 UTC
You can change the Python version for 2.6(Python2.6).

Comment 12 Akira TAGOH 2013-10-24 07:14:57 UTC
wrong bug? no python code in im-chooser nor imsettings though


Note You need to log in before you can comment on or make changes to this bug.