This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 70354 - Burning CD with Freecom drive over 300MB crashes kernel
Burning CD with Freecom drive over 300MB crashes kernel
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 15:06 EDT by Andrew Jones
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 21:59:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
syslog entries (2.47 KB, text/plain)
2002-07-31 15:07 EDT, Andrew Jones
no flags Details
Finally got the complete, normal console output on crash. (1.48 KB, text/plain)
2002-07-31 16:24 EDT, Andrew Jones
no flags Details
Console dump (9.87 KB, text/plain)
2003-06-05 01:26 EDT, Andrew Jones
no flags Details

  None (edit)
Description Andrew Jones 2002-07-31 15:06:14 EDT
Description of Problem:
I have successfully been burning CDs with my Freecom CD writer (USB) for a while
now (patches for RedHat), but recently the volume of data that i burn has
crossed the 300MB line. Now, about the time the burning process gets to 299 or
300 MB, the writer stops, and about a minute or two later, the computer crashes.


Version-Release number of selected component (if applicable):
2.4.18-5


How Reproducible:
Always.


Steps to Reproduce:
1. Hook up a Freecom burner to the USB port and burn a CD larger than 300 MB.
2. 
3. 

Actual Results:
If i stay in graphical user mode, the machine simply locks up and the LEDs on
the keyboard flash. If i switch over to the first virtual console, i get lots of
kernel error messages (then it freezes up). Normally these do not appear in the
log, but i got lucky this time, and some were there.


Expected Results:
I really ought to be able to burn a CD.


Additional Information:
Athlon XP 1700+, Freecom drive that was part of a special deal through the
German company Karstadt, but it looks like nothing more than a repackaged
version of one of their portables.
Comment 1 Andrew Jones 2002-07-31 15:07:21 EDT
Created attachment 68044 [details]
syslog entries
Comment 2 Andrew Jones 2002-07-31 16:24:39 EDT
Created attachment 68084 [details]
Finally got the complete, normal console output on crash.
Comment 3 Andrew Jones 2002-08-02 15:16:03 EDT
I have come closer to finding the problem. It is NOT a problem of being able to
burn more than 300MB. One specific file in my possession will always cause this
problem. That file is openssl095a-0.9.5a-14.i386.rpm from the RedHat updates
download site (for 7.3). As i say, any time i burn that file (alone or with
other files), the machine crashes as soon as it starts burning the OpenSSL RPM.
Comment 4 Pete Zaitcev 2002-08-08 13:55:26 EDT
Man, I am sorry for all the blanks you had to waste to diagnose this.
Thanks for the perfect trace, I am looking into it. It is a tad
intricate though.
Comment 5 Andrew Jones 2002-08-20 14:16:02 EDT
CD-RW, my friend. Didn't waste a single blank. :) I have another bit of news
that probably won't help, but i'll toss it in for what it's worth: One of the
following three files causes the same thing: the LSB update RPM, the two libpng
update RPMs. Those being the most recent updates from RedHat's site, of course.
I can't tell You which one, because while trying to burn the CD last night, it
rebooted my system and hosed the root filesystem. It took some real magic to get
things working again, and in only 90 minutes, but with certain drawbacks (the
filesystem is no longer ext3; i had to revert back to ext2). Nonetheless, i
understandably approach burning another test CD with trepidation.
Comment 6 Andrew Jones 2002-10-17 12:30:05 EDT
Is anything happening on this bug? I'm still afraid to burn CDs, and i normally
burn patches for RedHat onto CD so i can always have it with me. Computer
security is my field, and i feel naked without up-to-date patches...
Comment 7 Pete Zaitcev 2002-10-17 12:33:12 EDT
Sorry to say, stalled.
Comment 8 Pete Zaitcev 2003-06-04 00:10:36 EDT
Can you try with the receint errata 2.4.20-18, please?
Sorry to waste your wonderful console capture... I need something
fresher to press it with upstream.
Comment 9 Andrew Jones 2003-06-05 01:24:48 EDT
No problem! Okay, for the record:
<4 arjones@server ~>uname -a
Linux server.pipasoft.com 2.4.20-18.9 #1 Thu May 29 06:54:41 EDT 2003 i686
athlon i386 GNU/Linux
Obviously (from the kernel version), this is RH 9.

Change in results: This time, there were no blinking LED's, and the machine did
not crash so absolutely as before. This time, freecom reset was called, and so
on and so forth, as seen in the (new) attached dump, and there was output to the
console due to a NULL pointer dereference, but the machine was still sort of
hobbling along. Anything i tried to do after that, though (including logging in
from a virtual console as root so i could try rebooting) brought more console
dumps (everything after the first one in the attachment), until eventually
nothing could be done but hard reboot the machine.
Comment 10 Andrew Jones 2003-06-05 01:26:17 EDT
Created attachment 92153 [details]
Console dump
Comment 11 Pete Zaitcev 2003-06-05 17:34:55 EDT
We have 2.4.20-18.7, which at least should fix the oops.
One other guy says the freecom still does not work properly.
Would you test and provide some report?
Comment 12 Andrew Jones 2003-06-18 16:21:24 EDT
I'm sorry to take so long getting back to You, but i'm VERY busy at the moment.

I'm afraid that i don't understand what You want me to test. Did You want me to
test 2.4.20-18.7? I guess i could do that (though probably not for another 2
weeks or more), though i personally fail to see the point. I use Red Hat Linux 9
now...

Could You please clarify Your comments? Thanks!
Comment 13 Pete Zaitcev 2003-09-29 14:05:32 EDT
I meant that all the io_requiest_lock dropping and also SMP fixes
to usb-uhci might make a difference. Of course, if you move to RHL 9,
it's only to the better; the only difference would be that release
suffix is going to be .9 in errata kernels. All 2.4.20's are done
from the same source.

How does the 2.4.20-20.9 work?

I suspect you cannot live that long without a burner, so what's the
workaround? Burning small images only?

Note You need to log in before you can comment on or make changes to this bug.