Bug 703569 - No user login dialog on boot-up when SSSD is enabled
Summary: No user login dialog on boot-up when SSSD is enabled
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: accountsservice
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 699921 (view as bug list)
Depends On:
Blocks: F15Blocker, F15FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2011-05-10 17:22 UTC by James Laska
Modified: 2013-09-02 06:57 UTC (History)
6 users (show)

Fixed In Version: accountsservice-0.6.10-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:31:19 UTC


Attachments (Terms of Use)
Screenshot.png (367.52 KB, image/png)
2011-05-10 17:22 UTC, James Laska
no flags Details
Screenshot.png (showing fix) (363.44 KB, image/png)
2011-05-10 19:24 UTC, James Laska
no flags Details

Description James Laska 2011-05-10 17:22:53 UTC
Created attachment 498111 [details]
Screenshot.png

Description of problem:

After installing F15-Final-TC1, and enabling SSSD (LDAP ident and krb5 auth) during firstboot, the gdm greeter does not offer a 


Version-Release number of selected component (if applicable):
 * gdm-3.0.0-3.fc15.x86_64
 * accountsservice-0.6.9-5.fc15.x86_64

How reproducible:
 * 100%

Steps to Reproduce:
1. Install F-15-Final-TC1 (you can enable or disable 'updates-testing' ... shouldn't matter)
2. After install, during firstboot, enable SSSD for user accounts (LDAP ident and krb5 auth)
3. Complete firstboot and proceed
  
Actual results:

GDM starts, and displays the Fedora logo ... but there is no 'Other...' option to enter a username to login as.

Expected results:

The gdm-greeter should have offered a way for users to login

Additional info:

 * I think this is a clear-cut blocker if it was affecting *all* users.  However, SSSD is enabled by default, so *anyone* using network ident or auth will be impacted by this problem.  Therefor, I think the exposure is still high enough to consider this as a blocker for the following criteria ...

   "When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should provide a working login prompt without any unintended user intervention when boot is complete, and all virtual consoles intended to provide a working login prompt should do so "

Comment 1 Adam Williamson 2011-05-10 18:19:06 UTC
yeah, this is a bit borderline on the exposure question, but the impact is significant enough to make me +1 blocker on this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Fedora Update System 2011-05-10 19:19:10 UTC
accountsservice-0.6.10-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/accountsservice-0.6.10-2.fc15

Comment 3 James Laska 2011-05-10 19:24:18 UTC
Created attachment 498132 [details]
Screenshot.png (showing fix)

(In reply to comment #2)
> accountsservice-0.6.10-2.fc15 has been submitted as an update for Fedora 15.
> https://admin.fedoraproject.org/updates/accountsservice-0.6.10-2.fc15

Yay, fixes the reported problem for me!!!   Thank you :)

Comment 4 James Laska 2011-05-10 23:09:38 UTC
Given the feedback from awilliam, myself and from Ray on IRC ... I'm marking this as an approved blocker for the time being.  We can revert that decision should additional votes surface that warrant a change.

Comment 5 Fedora Update System 2011-05-11 05:48:36 UTC
Package accountsservice-0.6.10-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing accountsservice-0.6.10-2.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/accountsservice-0.6.10-2.fc15
then log in and leave karma (feedback).

Comment 6 James Laska 2011-05-11 11:32:37 UTC
Based on comments4 and feedback from sgallagh in the bodhi update, I'm marking this issue as VERIFIED.

Comment 7 Ray Strode [halfline] 2011-05-11 17:45:35 UTC
*** Bug 699921 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2011-05-14 04:04:49 UTC
accountsservice-0.6.10-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Ray Strode [halfline] 2011-05-19 02:17:27 UTC
*** Bug 705805 has been marked as a duplicate of this bug. ***

Comment 10 Marcus Moeller 2011-05-19 11:51:41 UTC
Problem still exist with latest accountsservice as described in https://bugzilla.redhat.com/show_bug.cgi?id=699921

Not sure if it's even related to this bug but Ray has merged it. I was talking about a freeze during password stage, not a missing 'Other' option.

Greets
Marcus

Comment 11 Marcus Moeller 2011-05-19 11:53:48 UTC
Sorry, meant Bug 705805

Comment 12 James Laska 2011-05-19 13:31:19 UTC
This bug deals specifically with not getting a prompt when SSSD is configured.  The issue you describe sounds like a freeze at the password prompt?  Please file a new bug, or track that against the issue you noted.  The reported problem of not getting a user (or password) prompt with SSSD enabled has been resolved.  Thanks!

Comment 13 Marcus Moeller 2011-05-19 14:00:15 UTC
As mentioned, I have filed a separate bug, but Ray marked it as duplicate. I am going to unmark it.


Note You need to log in before you can comment on or make changes to this bug.