Bug 703625 - BCM4312 wireless w/ b43 driver and broadcom-wl-4.150.10.5 firmware associates, works for a while, drops the connection, and then fails to reconnect.
BCM4312 wireless w/ b43 driver and broadcom-wl-4.150.10.5 firmware associate...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
15
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-10 16:19 EDT by Grant Goodyear
Modified: 2012-10-30 11:56 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 871210 (view as bug list)
Environment:
Last Closed: 2012-08-07 11:58:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grep NetworkManager /var/log/messages (27.34 KB, text/plain)
2011-05-10 17:15 EDT, Grant Goodyear
no flags Details
`cat /var/log/messages | grep NetworkManager` from Dell Latitude D420 (115.09 KB, text/plain)
2011-05-18 03:13 EDT, James Tuttle
no flags Details

  None (edit)
Description Grant Goodyear 2011-05-10 16:19:55 EDT
Description of problem:

I have an HP netbook with a BCM4312 wireless chip.  I downloaded and used b43-fwcutter to install the broadcom-wl-4.150.10.5 firmware following the directions for Fedora on http://linuxwireless.org/en/users/Drivers/b43.

I have no problem associating with my unsecured network.  Network manager finds the access point and associates just fine.  Wifi works just fine, as far as I can tell, for a variable amount of time and/or network traffic, and then the connection drops and I can't get it to reconnect without rebooting.


Version-Release number of selected component (if applicable):

wpa_supplicant-0.7.3-4.fc15.i686 and wpa_supplicant-0.7.3-6.fc15.i686


How reproducible:

Perfectly.  Both with a preupgrade-installed version of F15, and a complete wipe-and-install.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

The wpa_supplicant.log isn't particularly helpful:

   CTRL-EVENT-DISCONNECTED bssid=00:0f:66:91:ce:9c reason=4

I updated libeap and wpa_supplicant to 0.7.3-8.fc15.i686 (grabbed from koji, with thanks to Aron Griffis for the pointer).  I don't know yet if it has solved the problem.
Comment 1 Grant Goodyear 2011-05-10 16:53:56 EDT
Looks like the new version of wpa_supplicant is working.  If my netbook can manage staying connected overnight, I'll close this bug.
Comment 2 Grant Goodyear 2011-05-10 17:15:05 EDT
Created attachment 498168 [details]
grep NetworkManager /var/log/messages

NetworkManager associates to the open wifi around 15:19, and the connection is dropped around 16:20 and fails to reassociate.
Comment 3 Grant Goodyear 2011-05-10 17:15:59 EDT
No joy.  Still having problems, so attached the NetworkManager log above.  Darn.
Comment 4 Grant Goodyear 2011-05-11 12:07:53 EDT
According to http://linuxwireless.org/en/users/Drivers/b43, a BCM4312-based card should use version 4.174.64.19 (labeled as 4.178.10.4 at downloads.openwrt.org) instead.  So, I replaced the existing firmware in /lib/firmware with that from the 4.178.10.4 tarball.  Same problem.  Activation successful at 09:35:26, and at 09:54:52 the supplicant interface state changed to disconnected.
Comment 5 Grant Goodyear 2011-05-11 16:12:53 EDT
For comparison, and to make sure that there hasn't been a hardware failure, I wiped my netbook and installed F14 along with the 4.150.10.5 firmware.  Wifi appears to be stable now.
Comment 6 James Tuttle 2011-05-18 03:09:35 EDT
I believe (based on comparing logs and behavior) that I am experiencing the same issue.

Hardware is a Dell Latitude D420, which contains a Broadcom BCM4312 (in the form of a Dell Wireless 1490).  It has a fresh install of F13 with all current updates as of 18 May 2011.  Kernel is 2.6.34.8-68.fc13.i686.

Behavior is identical to what Grant describes.  The machine will connect just fine off of a fresh boot or on coming up from standby, but after an unpredictable amount of time the wireless connection will be dropped.  The system will prompt the user repeatedly to enter the WPA key, but it will not reconnect until the system is either rebooted or put into standby and brought back out again.

I will attach the output of `cat /var/log/messages | grep NetworkManager` over a period of time in which the issue manifested itself several times.  I can provide other logs and diagnostic output as desired.
Comment 7 James Tuttle 2011-05-18 03:13:04 EDT
Created attachment 499532 [details]
`cat /var/log/messages | grep NetworkManager` from Dell Latitude D420

Possibly relevant /var/log/messages lines from a fresh F13 install on a Dell Latitude with a Broadcom BCM4312 wireless.
Comment 8 Dan Beard 2011-05-22 07:29:47 EDT
Same issue here.   Annoying as the devil.   Died in the middle of this report.   

Machine here is an HP dv9904ca, and the running kernel is unknown at this point.   I forgot to write it down before I booted into Mint-10 in order to post this, but it was the last updated kernel as of yesterday evening.
Comment 9 Dan Beard 2011-05-29 21:08:16 EDT
Still an issue here.   Connection randomly fails, and will not re-connect.

If I had to guess, I'd say the radio is shutting down.

Same system works peachy keen fine and consistently with MINT-10.
Comment 10 James Tuttle 2011-06-07 13:42:17 EDT
Just wanted to comment that the issue happened again yesterday, after the upgrade to F15.  Exact same behavior: system drops wireless connection, begins searching, tries to reconnect and prompts for WPA password, but then will not reconnect until I put it into standby and bring it back.
Comment 11 Benjamin Kriss 2011-07-01 06:54:25 EDT
Getting the exact same issue. Has there been any progress on this?
I have tried using the latest b43-fwcutter (version 014, not available in the repos) with more up-to-date firmware, but the problem persists.
Comment 12 Stef Walter 2011-09-25 01:48:00 EDT
I'm experiencing this as well, and willing to work with Fedora developers on this. This did not occur on Ubuntu on the same hardware.
Comment 13 David Woodhouse 2011-10-01 06:53:39 EDT
What kernel version is working? Sounds like a git-bisect may find the offending change. If Ubuntu works and Fedora doesn't, that usually just means it's something that changed from one version of the kernel to another, so it'll be the other way round next time there's an update.
Comment 14 Fausto 2011-11-10 12:48:50 EST
The issue also happens on a fresh Fedora 16 installation using a BCM4311 wifi adapter (on a Dell Inspiron 1501).

In my case unloading the kernel module and reloading it (modprobe -r b43;modprobe b43) brings the wifi back for a while (after an unpredictable amount of time it drops again and I have to repeat the process).
Comment 15 FNeira 2012-02-22 14:57:35 EST
Hardware: Acer Aspire One (Model KAV60) fresh install of Fedora 16 XFCE replaced  Fedora LXDE and Fedora Security previous installs (I suspected from the spins).

Exactly the same symptoms: Random time with connection thru BCM 4312 and suddenly lost. To reenable, a reboot is required.
Comment 16 Grant Goodyear 2012-04-23 12:57:37 EDT
Problem seems to have gone away w/ F17 (for me, anyway).
Comment 17 Fedora End Of Life 2012-08-07 11:58:55 EDT
This message is a notice that Fedora 15 is now at end of life. Fedora
has stopped maintaining and issuing updates for Fedora 15. It is
Fedora's policy to close all bug reports from releases that are no
longer maintained. At this time, all open bugs with a Fedora 'version'
of '15' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that
we were unable to fix it before Fedora 15 reached end of life. If you
would still like to see this bug fixed and are able to reproduce it
against a later version of Fedora, you are encouraged to click on
"Clone This Bug" (top right of this page) and open it against that
version of Fedora.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

The process we are following is described here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Stuart D Gathman 2012-10-29 19:01:50 EDT
I am still getting this problem on F17.  I can disable wireless, unload the b43 driver, load it, and reenable wireless to "fix" it (so clearly, even if a hardware problem, it could be worked around in software).  I have a Dell Inspiron 1501 with bcm4311.
Comment 19 Stuart D Gathman 2012-10-30 11:56:53 EDT
Reopened for F17 as bug#871210

Note You need to log in before you can comment on or make changes to this bug.