Bug 703703 - setup-ds-admin.pl asks for legal agreement to a non-existant file
setup-ds-admin.pl asks for legal agreement to a non-existant file
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Install/Uninstall (Show other bugs)
1.2.9
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Nathan Kinder
Ben Levenson
: screened
Depends On:
Blocks: 690318 389_1.2.9 726742
  Show dependency treegraph
 
Reported: 2011-05-11 01:29 EDT by James Livingston
Modified: 2016-02-21 19:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-10 13:40:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-Bug-703703-setup-ds-admin.pl-asks-for-legal-agreemen.patch (2.86 KB, patch)
2011-06-20 15:11 EDT, Rich Megginson
nkinder: review+
Details | Diff

  None (edit)
Description James Livingston 2011-05-11 01:29:58 EDT
Description of problem:
setup-ds-admin.pl requires that you agree to be bound by the agreement in "LICENSE.TXT". That is no file with that name.

I guess it is referring to /usr/share/doc/389-admin-1.1.16/LICENSE, but since it's asking for legal agreement, it would be good not to guess and point to the exact path of the file I'm supposed to be agreeing to


Version-Release number of selected component (if applicable):
1.1.16-1.fc14

How reproducible:
always

Steps to Reproduce:
1. Run setup-ds-admin.pl
2. Take note of the file name it says the licence is in
3. Try to find the file, to read it before agreeing
  
Actual results:
Cannot find the file

Expected results:
To be able to find the file

Additional info:
Comment 1 Rich Megginson 2011-06-17 21:20:26 EDT
There are actually several different licenses
directory server is GPLv2 + plugin exception
admin server is mostly GPLv2 except for the Apache modules which are APL2
the rest of the components are GPLv2 or LGPLv2

What about something like this:

BY SETTING UP AND USING THIS SOFTWARE YOU ARE CONSENTING TO BE BOUND BY
THE TERMS OF THE LICENSES OF THE DIRECTORY SERVER AND OTHER COMPONENTS
USED BY THIS SOFTWARE.  THE LICENSES FOR DIRECTORY SERVER AND OTHER
COMPONENTS ARE FOUND IN FILES CALLED 'LICENSE' IN THE DOCUMENTATION
DIRECTORY FOR EACH COMPONENT.  IF YOU DO NOT AGREE TO ALL OF THE TERMS
OF THE LICENSES, PLEASE DO NOT SET UP OR USE THIS SOFTWARE.

Do you agree to the license terms? [no]:


Is this too cumbersome?
Comment 2 Nathan Kinder 2011-06-20 12:51:11 EDT
(In reply to comment #1)
> There are actually several different licenses
> directory server is GPLv2 + plugin exception
> admin server is mostly GPLv2 except for the Apache modules which are APL2
> the rest of the components are GPLv2 or LGPLv2
> 
> What about something like this:
> 
> BY SETTING UP AND USING THIS SOFTWARE YOU ARE CONSENTING TO BE BOUND BY
> THE TERMS OF THE LICENSES OF THE DIRECTORY SERVER AND OTHER COMPONENTS
> USED BY THIS SOFTWARE.  THE LICENSES FOR DIRECTORY SERVER AND OTHER
> COMPONENTS ARE FOUND IN FILES CALLED 'LICENSE' IN THE DOCUMENTATION
> DIRECTORY FOR EACH COMPONENT.  IF YOU DO NOT AGREE TO ALL OF THE TERMS
> OF THE LICENSES, PLEASE DO NOT SET UP OR USE THIS SOFTWARE.
> 
> Do you agree to the license terms? [no]:
> 
> 
> Is this too cumbersome?

I think that this is a good idea since there are different licenses for different components.
Comment 3 Rich Megginson 2011-06-20 14:18:54 EDT
Just spoke to Richard Fontana - according to him, we don't need to display or require the user to accept any EULA during setup.  So the right answer is to just get rid of this screen.
Comment 4 Rich Megginson 2011-06-20 15:11:39 EDT
Created attachment 505674 [details]
0001-Bug-703703-setup-ds-admin.pl-asks-for-legal-agreemen.patch
Comment 5 Rich Megginson 2011-06-20 16:10:29 EDT
To ssh://git.fedorahosted.org/git/389/ds.git
   2568704..c8e821c  master -> master
commit c8e821c11ec22c2b67cbaf0fa3f587778db223d9
Author: Rich Megginson <rmeggins@redhat.com>
Date:   Mon Jun 20 13:07:12 2011 -0600
    Reviewed by: nkinder (Thanks!)
    Branch: master
    Fix Description: According to the Red Hat Legal department, we do not need
    to display or ask the user to accept the EULA any more.  The EULA dialog
    and text has been removed.
    Platforms tested: RHEL6 x86_64
    Flag Day: no
    Doc impact: Yes - will need a slight amendment to the Install Guide.

Note You need to log in before you can comment on or make changes to this bug.