Bug 70380 - bootloader --location=partition is ignored in kickstart file
bootloader --location=partition is ignored in kickstart file
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 71700 (view as bug list)
Depends On:
Blocks: 67217 79578
  Show dependency treegraph
 
Reported: 2002-07-31 18:12 EDT by Alexandre Oliva
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-22 21:40:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2002-07-31 18:12:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020722

Description of problem:
A kickstart file containing the following line:

bootloader --location=partition --append "ide0=ata66 ide1=ata66" --md5pass=<omitted>

installs grub in the MBR of the boot disk.  Oops.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a complete kickstart file (i.e., one that doesn't require any
interaction) containing --location=partition for the boot loader.
2.Install with it.
3.Restart the system and hope the original install, that should have been
preserved, still works.
	

Actual Results:  The preserved partitions are all there, but the boot record was
replaced, and it did NOT install the boot sector in the beginning of the /boot
partition.  Oops.

Expected Results:  It should do as it was told.

Additional info:
Comment 1 Jeremy Katz 2002-08-02 04:23:02 EDT
Fixed in CVS
Comment 2 Jeremy Katz 2002-08-16 17:49:02 EDT
*** Bug 71700 has been marked as a duplicate of this bug. ***
Comment 3 Mike McLean 2003-01-22 14:36:09 EST
see also bug#64342
Comment 4 Mike McLean 2003-01-22 21:40:58 EST
'bootloader --location=partition' confimed to work with Phoebe-beta4. closing out.

Note You need to log in before you can comment on or make changes to this bug.