Bug 703815 - The pre-release warning window should be removed
Summary: The pre-release warning window should be removed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pungi
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-05-11 10:25 UTC by He Rui
Modified: 2013-01-10 06:36 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-10 20:24:57 UTC
Type: ---


Attachments (Terms of Use)
Warning window (32.28 KB, image/png)
2011-05-11 10:25 UTC, He Rui
no flags Details
Add --isbeta flag (2.78 KB, patch)
2011-05-11 19:05 UTC, Chris Lumens
no flags Details | Diff

Description He Rui 2011-05-11 10:25:56 UTC
Created attachment 498247 [details]
Warning window

Description of problem:
A reminder that the 'pre-release software' warning window should be removed before it's formally released, marked it as F15Blocker.


Version-Release number of selected component (if applicable):
anaconda 15.31

Comment 1 Martin Gracik 2011-05-11 11:16:31 UTC
The prerelease window is shown if the composes are made with isBeta flag enabled. This is not a bug. The window is there because it's still a prerelease.

Comment 2 James Laska 2011-05-11 11:31:21 UTC
Thanks Hurry ... I had a similar concern earlier this week.  After talking to clumens, he confirmed what Martin indicated above.  The correct change needed here is to have fedora-release updated.

That is planned by rel-eng and will be tracked in https://fedorahosted.org/rel-eng/ticket/4700

Comment 3 James Laska 2011-05-11 15:20:25 UTC
I just tested with the latest fedora-release package [1].  It seems that isBeta=True is still set in /.buildstamp.  Seems perhaps an additional lorax or pungi fix will be needed still to remove the betanag

I'd like to add whiteboard:AcceptedBlocker since this is clearly something we can't ship with, but I want to figure out how best to apply it to the criteria first.

[1] https://admin.fedoraproject.org/updates/fedora-release-15-1

Comment 4 James Laska 2011-05-11 15:21:20 UTC
Clumens is investigating, this may be fixed in pungi, or in lorax.  I'm not yet clear on the ideal solution at this time.

Comment 5 Martin Gracik 2011-05-11 15:30:56 UTC
In pungi's __init__.py lines 842-845... We need to get the is_beta value from somewhere (I don't know where) in pungi, and pass it to lorax.

         # FIXME get the actual is_beta value
         lorax.run(self.ayum, product=product, version=version,
                   release=release,
                   variant=variant, bugurl=bugurl, is_beta=True,
                   workdir=workdir, outputdir=outputdir)

Comment 6 Chris Lumens 2011-05-11 15:34:23 UTC
Testing a pungi patch right now.  Stand by.

Comment 7 Chris Lumens 2011-05-11 19:05:51 UTC
Created attachment 498374 [details]
Add --isbeta flag

Comment 8 James Laska 2011-05-11 19:10:44 UTC
(In reply to comment #6)
> Testing a pungi patch right now.  Stand by.

Using the supplied patch, the betanag does *not* appear.  

While we don't have release criteria that explicitly note that the betanag must be removed, this is a high severity issue in pungi that results in a betanag for *all* users.  I guarantee we'd have to respin to address this, and I wouldn't be comfortable releasing a product that had a "Warning, this is pre-release software" as the first screen.

Comment 9 He Rui 2011-05-12 02:52:57 UTC
Verified it fixed in F15-Final-RC1

Comment 10 James Laska 2011-05-12 12:13:15 UTC
(In reply to comment #9)
> Verified it fixed in F15-Final-RC1

Will mark as VERIFIED once there is an official fix posted to git (and packaged).  Assigned to dgilmore for further handling.

Comment 11 James Laska 2011-05-13 12:10:12 UTC
dgilmore: Hi Dennis!  I'd like to move this out of ASSIGNED if possible.  I know you have a one-off change to address Final RC composes, is there a permanent fix for this in git already?

Comment 12 Dennis Gilmore 2011-05-13 12:28:04 UTC
there is not yet a patch applied upstream, im going to work on one today

Comment 13 James Laska 2011-05-16 20:17:03 UTC
(In reply to comment #12)
> there is not yet a patch applied upstream, im going to work on one today

Hey Dennis, sorry to keep bugging on this one.  Hoping to get this off our unresolved blocker list.  Do you think we'll be able to move this out of ASSIGNED by the go/no_go meeting tomorrow (May 17 @ 17:00 EDT)?

Comment 14 Adam Williamson 2011-05-17 21:23:43 UTC
Marking this as not a release blocker any more: per agreement at the go/no-go meeting today it is no longer blocking the release, as dgilmore patched it in RC3 compose. So it's still a bug until pungi is fixed, but it is not blocking F15.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 15 James Laska 2011-05-18 11:57:42 UTC
Patch in git to address this issue for future releases ...

http://git.fedorahosted.org/git/?p=pungi.git;a=commitdiff;h=80120d1e5355adc6a7c66213ef31e19b51a80cf6

Comment 16 Fedora Admin XMLRPC Client 2012-02-10 18:58:51 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 17 Dennis Gilmore 2012-02-10 20:24:57 UTC
This has long been fixed. and commited upstream


Note You need to log in before you can comment on or make changes to this bug.