Bug 70392 - Mouse died during X configuration
Mouse died during X configuration
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-31 20:31 EDT by Kris Urquhart
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-02 14:53:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kris Urquhart 2002-07-31 20:31:21 EDT
Description of problem:
When configuring X during install of limbo2, I was testing different 
resolutions.  After the second test, the mouse was dead.  I was able to proceed 
with the install using tab keys.

After reboot, the X server would not start:
(EE) xf860OpenSerial: Cannot open device /dev/psaux
   No such device or address
(EE) Mouse0: cannot open input device
(EE) PreInit failed for input device "Mouse0"
  No core pointer

How reproducible:
Didn't try
Comment 1 Kris Urquhart 2002-08-01 00:19:42 EDT
I thought this was worth reproducing, so I redid the install.  This time the 
mouse froze during the first test (when I went to click on the OK during the 
ten second countdown).

I then redid the entire install for the third time, but did not do any X tests, 
and everything went fine.  After Gnome started up, I was not happy with the low 
resolution, so I ran redhat-config-xfree86 and the mouse died yet again and I 
cannot start X (no core pointer).

Well, at least I am exercising the installer ;)
Comment 2 Michael Fulbright 2002-08-01 01:42:37 EDT
What video/mouse hardware are we looking at here?
Comment 3 Kris Urquhart 2002-08-01 09:21:09 EDT
ATI Mach64 3D Rage IIC video card
Logitech 3-button PS/2 mouse
Comment 4 Kris Urquhart 2002-08-01 12:32:42 EDT
I installed yet again, but saved my XF86config before and after changing 
resolutions.  I tried to create attachments, but Bugzilla is crapping out on 
me.  Is there a particular section of either file that you would like me to 
paste directly?
Comment 5 Kris Urquhart 2002-08-01 13:21:56 EDT
I have found that once the mouse is dead, reinstating a known good XF86config
and restarting X is not sufficient to get it back.  Rebooting does recover the
mouse, even with what was a suspect XF86config.  So at this point, I don't think
it is XF86config related, but instead some problem with /dev/psaux.  Any clues
on how to debug this further?
Comment 6 Kris Urquhart 2002-08-02 14:53:02 EDT
Sorry, but this is most likely a hardware issue.  I had recently moved my
computer and added and PS/2 extension cable to the mouse.  When I plug the mouse
into the kvm box directly without the extension cable, all is well.  

Not sure why the extension cable works fine with the other two computers on the
same KVM (RH 7.2 and Windows ME)?
Comment 7 Michael Fulbright 2002-08-05 12:09:51 EDT
KVMs are known to do wierd voodoo :)


Note You need to log in before you can comment on or make changes to this bug.