Bug 70397 - grubby segfault when installing a new kernel
grubby segfault when installing a new kernel
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: mkinitrd (Show other bugs)
1.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-31 21:14 EDT by Fortepianissimo
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-01 13:41:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fortepianissimo 2002-07-31 21:14:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020718

Description of problem:
installing a new kernel resulted in an error message which indicated the demise
of grubby.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -Uvh kernel-<version>.<arch>.rpm
2.
3.
	

Actual Results:  the kernel installed fine, but /etc/grub.conf is not updated,
and an error message is shown:

/sbin/new-kernel-pkg: line 247: 30122 Segmentation fault      /sbin/grubby
--add-kernel=/boot/vmlinuz-$version $INITRD --copy-default --title "$title"
--args="root=$rootdevice" --remove-kernel="TITLE=$title"


Expected Results:  the kernel should be installed, and /etc/grub.conf should be
updated.

Additional info:
This is for mkinitrd-3.4.20-1.
Comment 1 Erik Troan 2002-07-31 21:35:37 EDT
Can you send the grub.conf you're using?
Comment 2 Fortepianissimo 2002-07-31 22:02:40 EDT
Here is my /etc/grub.conf:

--- cut here ---
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You do not have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /, eg.
#          root (hd0,0)
#          kernel /boot/vmlinuz-version ro root=/dev/hda1
#          initrd /boot/initrd-version.img
#boot=/dev/hda
default=1
timeout=10
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
password --md5 ...<snipped>
title Red Hat Linux (2.4.18-7.82)
        root (hd0,0)
        kernel /boot/vmlinuz-2.4.18-7.82 ro root=LABEL=/ hdd=ide-scsi
        initrd /boot/initrd-2.4.18-7.82.img
title 2.4.19-rc4
        root (hd0,0)
        kernel /boot/vmlinuz-2.4.19-rc4
--- cut here ---

This is to upgrade from .82 to .85 kernel.
Comment 3 Erik Troan 2002-08-01 13:41:06 EDT
I can't reproduce this, but someone else is seeing it so it's definitely for real.

Can you build a debug version of grubby and try to get a stack trace? The grub
invocation:

    grubby --add-kernel=/boot/vmlinuz-2.4.15 --copy-default --title title
            --args="root=LABEL=/" --remove-kernel="TITLE=$title"

should be enough to reproduce this w/o having to run rpm or new-kernel-pkg. If
this doesn't cause a segv, let me know. If it does, a stack trace would be very
helpful.
Comment 4 Erik Troan 2002-08-07 17:52:04 EDT
Jeremey got this fixed -- I couldn't reproduce it because it was already taken
care of in CVS.

Note You need to log in before you can comment on or make changes to this bug.