Bug 703997 - accessibility objects named the same thing
accessibility objects named the same thing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Bryan Kearney
J.C. Molet
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-05-11 15:59 EDT by J.C. Molet
Modified: 2013-01-10 05:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:14:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
accessibility (169.50 KB, image/png)
2011-05-11 15:59 EDT, J.C. Molet
no flags Details

  None (edit)
Description J.C. Molet 2011-05-11 15:59:19 EDT
Created attachment 498385 [details]
accessibility

Description of problem:
When trying to interact with the 'Invalid Product List' in the subscription assistant, I often get a 'Object not table type' error.  I believe this is because the table and the container that the table is in are named the same thing.

Version-Release number of selected component (if applicable):
subscription-manager-gnome-0.96.1-1.git.180.651ce37.el6.x86_64
(occurs in all branches)

How reproducible: often


Steps to Reproduce:
1. Start subscription manager gui with accessibility enabled
2. use your favorite accessibility access tool
3. try to obtain a hook into the "Invalid Product List" table.
 - eg: getrowcount("Subscription Assistant") ("Subscription Assistant" "Invalid Product List")
  
Actual results:
The object returned is the container that the table is in and not the table itself.

Expected results:
The table object is returned.

Additional info:
Using the other conventions in subscription manager, the container would be named "Invalid Product List Box" or similar.

This occurs on all branches and affects automation of this feature.
Comment 1 James Bowes 2011-07-27 09:42:08 EDT
fixed in master, a46fb73af3e9
Comment 2 J.C. Molet 2011-07-28 08:34:03 EDT
The container box is now named "Invalid Product List Scroller".  Moving to VERIFIED.

subscription-manager-gnome-0.96.4-1.git.65.a46fb73.el6.x86_64
Comment 3 errata-xmlrpc 2011-12-06 12:14:08 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.