Bug 704030 - package conflicts in 15 Final RC1
package conflicts in 15 Final RC1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
15
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F15Blocker/F15FinalBlocker
  Show dependency treegraph
 
Reported: 2011-05-11 17:24 EDT by Andre Robatino
Modified: 2011-05-15 12:22 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-15 12:22:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2011-05-11 17:24:10 EDT
Description of problem:
Output from https://fedoraproject.org/wiki/QA:Testcase_Mediakit_FileConflicts (either i386 or x86_64, they are identical):

0 file conflicts found.
3 package conflicts found.

== Package conflicts ==
astronomy-bookmarks-1-7.fc15.noarch
fedora-bookmarks-15-0.1.noarch

fedora-logos-15.0.0-3.fc15.noarch
generic-logos-15.0.0-1.fc15.noarch

fedora-release-15-1.noarch
generic-release-15-0.4.noarch

Version-Release number of selected component (if applicable):
15 Final RC1 DVD
Comment 1 Bill Nottingham 2011-05-11 18:10:06 EDT
generic-* and astronomy-* shouldn't be on the media kit.
Comment 2 James Laska 2011-05-11 20:30:13 EDT
(In reply to comment #1)
> generic-* and astronomy-* shouldn't be on the media kit.

No, they shouldn't

# ll /media/Packages/generic*
-rw-rw-r--. 3 root root 1263248 Mar 22 23:21 /media/Packages/generic-logos-15.0.0-1.fc15.noarch.rpm
-rw-rw-r--. 3 root root   19388 Feb 12 00:19 /media/Packages/generic-release-15-0.4.noarch.rpm
Comment 3 James Laska 2011-05-11 20:33:31 EDT
+1 Blocker for the Alpha release criteria [1] "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (CD/DVD) install "

Repodiff between TC1 and RC1 shows generic*rpm packages being added - http://fpaste.org/O3k1/

[1] https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria
Comment 4 Bruno Wolff III 2011-05-11 21:29:26 EDT
How are you doing the build? generic* and astronomy-bookmarks are already excluded and appear to have been for some time.
I suspect that someone did a repo override incorrectly. If you do one you need to still use the --excludes from the normal repo command.
Comment 5 Adam Williamson 2011-05-11 22:14:01 EDT
not sure what's going on here, though obviously generic-* should be rebuilt to match fedora-* , I still can't see why they're included; the new fedora-* packages don't seem to be missing any files or provides. Though fedora-release should have the release notes in it, shouldn't it?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Bruno Wolff III 2011-05-11 22:37:47 EDT
Pungi has an inclusive resolver. It will bring in all packages that satisfy a dependency. To keep stuff out you need to use --excludes on the repo definition. If someone were to use a substitute repo command (for example to point to a local mirror) without including the --excludes in the repo definition, all sorts of stuff that isn't supposed to get included will get pulled in.
Comment 7 James Laska 2011-05-12 07:35:17 EDT
Assigning to Fedora rel-eng (dennis@ausil.us).
Comment 8 Dennis Gilmore 2011-05-12 11:22:03 EDT
+1 blocker from me
Comment 9 Adam Williamson 2011-05-12 11:58:29 EDT
+1 blocker, obviously.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Adam Williamson 2011-05-15 12:22:55 EDT
This is fixed in RC2, I believe, and since it was simply down to the media creation commands - nothing that requires a package change - we can close it.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.