Bug 704050 - whenever booting, system clock has late 9 hours as compared with hwclock.
whenever booting, system clock has late 9 hours as compared with hwclock.
Status: CLOSED DUPLICATE of bug 709211
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-11 20:18 EDT by sangu
Modified: 2012-01-24 09:18 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-24 09:18:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2011-05-11 20:18:43 EDT
Description of problem:
# hwclock --show
Thu May 12 09:09:35 2011  -0.954298 seconds
# LANG=C date
Thu May 12 00:09:37 KST 2011
# cat /etc/adjtime 
1.124043 1305134811 0.000000
1305134811
LOCAL
# rdate -s time.bora.net
#  date
Thu May 12 09:09:57 KST 2011

$ cat /etc/sysconfig/clock 
# The time zone of the system is defined by the contents of /etc/localtime.
# This file is only for evaluation by system-config-date, do not rely on its
# contents elsewhere.
ZONE="Asia/Seoul"

Version-Release number of selected component (if applicable):
26-1.fc15.x86_64

How reproducible:
every time

Steps to Reproduce:
1. booting
2. $ date
3. # rdate -s time.bora.net
4. reboot

Actual results:


Expected results:


Additional info:

# systemctl status hwclock-load.service
hwclock-load.service - Apply System Clock UTC Offset
	  Loaded: loaded (/lib/systemd/system/hwclock-load.service)
	  Active: active (exited) since Thu, 12 May 2011 08:50:30 +0900; 21min ago
	 Process: 538 ExecStart=/sbin/hwclock --systz (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/hwclock-load.service



$ rpm -q initscripts
initscripts-9.30-2.fc15.x86_64
$ rpm -q initscripts-legacy
initscripts-legacy-9.30-2.fc15.x86_64
Comment 1 sangu 2011-05-12 02:25:47 EDT
After disable hwclock-load.service, this issue doesn't happen.
# systemctl disable hwclock-load.service
# rdate -s time.bora.net
# hwclock -w

reboot

# LANG=C hwclock ; LANG=C date
Thu May 12 15:23:34 2011  -0.579182 seconds
Thu May 12 15:23:34 KST 2011
Comment 2 Michal Schmidt 2011-05-12 05:54:44 EDT
Looks like something else is calling "hwclock --systz" one more time...

initscripts-legacy ships /lib/udev/rules.d/88-clock.rules which may be it. Does the bug go away if you uninstall initscripts-legacy?
Comment 3 Tomasz Torcz 2011-05-25 07:52:08 EDT
Does your /etc/adjtime contain "UTC" or "LOCAL" in third line?
Comment 4 Michal Schmidt 2011-05-25 08:31:43 EDT
(In reply to comment #3)
> Does your /etc/adjtime contain "UTC" or "LOCAL" in third line?

/etc/adjtime is in comment #0:

> # cat /etc/adjtime 
> 1.124043 1305134811 0.000000
> 1305134811
> LOCAL
Comment 5 Fedora Admin XMLRPC Client 2011-10-20 12:27:11 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Jóhann B. Guðmundsson 2012-01-24 08:39:54 EST
Is this still a problem or can this bug be closed?
Comment 7 Nicola Soranzo 2012-01-24 08:59:00 EST
hwclock-load.service is no more in systemd since v28:

http://lists.freedesktop.org/archives/systemd-devel/2011-May/002526.html

So this no more a problem for Fedora 16, but it may still occur in F15.
Comment 8 Nicola Soranzo 2012-01-24 09:18:20 EST

*** This bug has been marked as a duplicate of bug 709211 ***

Note You need to log in before you can comment on or make changes to this bug.